Idea ID: 2789899

open msoffice documents in Protected mode

Status : Waiting for Votes
Waiting for Votes
See status update history
over 4 years ago
Hi all.

We are running gw14.2.1 clients and MSOffice2010. MSOffice is configred to start in protected view when a document is opend in the temp Directory. This works fine when I open a file from explorer. But when I got a email with an office document and double click it to open it, it opens the document in unprotected mode. The temporary Document is found in the Temp Directory which is configured as untrusted path.

when starting word with Parameter /n ("C:\Program Files (x86)\Microsoft Off= ice\Office16\WINWORD.EXE" /n "%1") or without parameter. it works starting word with /vu "C:\Program Files (x86)\Microsoft Office\Office16\WI= NWORD.EXE" /vu "%1" it doesn't work. /vu is the standard for editing the document HKEY_LOCAL_MACHINE\SOFTWARE\C= lasses\Word.Document.12\shell\Edit\command\(Default) "C:\Program Files (x86= )\Microsoft Office\Office16\WINWORD.EXE" /vu "%1" /n is the standard for opening HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.D= ocument.12\shell\Open\command(Default) "C:\Program Files (x86)\Microsoft O= ffice\Office16\WINWORD.EXE" /n "%1" /o "%u"
Windows Explorer is triggering OPEN per default. Would be great if doubble clicking the attachment from the GW-Client is triggering open and not Editing.

Labels:

Windows Client