Using iManager 2.7 and Tomcat 5 with GroupWise 8 WebAccess

0 Likes

After some looking around and experimentation, I have found the answer to running the GroupWise 8 WebAccess & GroupWise 8 Publisher on the same Tomcat 5 instance that iManager 2.7 uses.



Although the Tomcat5.rpm from our distribution is necessary to install the WebAccess for GroupWise 8, It only has to be there when you start the WebAccess Configuration. After starting the WebAccess configuration, simply point it to your existing iManager 2.7 'webapps' directory, complete the configuration process, and then when you are done, make the following changes to the '/etc/apache2/conf.d/gw.conf' file. (What it puts in here is for the standard distro install of Tomcat 5)



Change the first two lines where is says:



ProxyPass /gw/webacc ajp://localhost:8009/gw/webacc
ProxyPass /gw/webpub ajp://localhost:8009/gw/webpub




so that it now says:



ProxyPass /gw/webacc ajp://localhost:9009/gw/webacc
ProxyPass /gw/webpub ajp://localhost:9009/gw/webpub




Notice the port number change.



Stop and start stop your Tomcat5 and Apache2 daemons now and you're all set.

Tags:

Labels:

How To-Best Practice
Comment List
Anonymous
Parents
  • This article relates to the Linux version, but I am having the same issue with Netware. NW65SP8 installs Tomcat5 and iManager 2.7 uses it, although Tomcat 4 is still being loaded.
    When Groupwise 8.0 webaccess application was installed it used Tomcat 4. Nothing loads unless Tomcat 4 and 5 are both running, but the /gw/webacc page comes up blank.

    I would like to try your solution, but there does not seem to be a corresponding gw.conf file in Netware.

    DavidR
Comment
  • This article relates to the Linux version, but I am having the same issue with Netware. NW65SP8 installs Tomcat5 and iManager 2.7 uses it, although Tomcat 4 is still being loaded.
    When Groupwise 8.0 webaccess application was installed it used Tomcat 4. Nothing loads unless Tomcat 4 and 5 are both running, but the /gw/webacc page comes up blank.

    I would like to try your solution, but there does not seem to be a corresponding gw.conf file in Netware.

    DavidR
Children
No Data
Related Discussions
Recommended