Cannot send mail to certain recipients. SMTP STARTTLS failure (8922)

1 Likes

Symptoms

Cannot mail certain recipients. The sender sees this in the GW Client:

 

 

 

The reason given for the delay: 420 TCP write error

 

 

 

The following is shown in the GWIA log:

 

 

 

07:11:54 2323 DMN: MSG 2815270 Attempting to connect to mail12.surftown.se 07:11:54 2323 DMN: MSG 2815270 Connected to [212.97.132.52] (mail12.surftown.se) 07:11:54 2323 DMN: MSG 2815270 SMTP STARTTLS failure (8922) 07:11:55 2323 DMN: MSG 2815270 SMTP session ended: [212.97.132.52] (mail12.surftown.se)

 

 

 

 

Diagnosis

The best way to troubleshoot this would be to get a packet trace. On the GWIA server:

 

 

 

tcpdump -i any -s 0 -w /root/surftown.cap host 212.97.132.52

 

 

 

This will capture data just for that ip. Note that you cannot filter on a single IP if the recipient has multiple ones.

Open the packet trace in Wireshark. Look at the client and server hellos:

Client Hello. That is you:

clipboard_image_0.png

You are indicating that you support TLS up to 1.2. Ideally the receiving mailserver should use that version, but instead:
 
clipboard_image_2.png
Here the receiving mailserver uses TLS 1.0 and that protocol is regarded as unsecure and was deprecated in June 2018. GW 18.2 will not talk to him.

Solution

Ask the admin of the receiving mailserver to upgrade to a supported version of SSL

Labels:

How To-Best Practice
Comment List
Anonymous
Parents
  • Hello community, how are you?, I hope everybody is fine.

    Here in Argentina and Chile have detected several clients that after migrating them to version 18.2.1 report problems sending emails to O365 domains.

    The error reported in the GWIA logs is 550 Host Unknown.

    After testing we have been able to detect that the GWIA uses TLS 1.0 regardless of the --sslOption that we use.
    If we make the GWIA relay via an AntiSpam, the emails arrive correctly at their destination, since the AntiSpam (MailCleaner, SMG, etc) has no problem using the new versions of TLS.

     

    wlucero_0-1592930632795.png

    Note: The minimum version accepted by O365 is 1.2.

    In the meantime, I just opened a SR.

    Bes regards.,

     

Comment
  • Hello community, how are you?, I hope everybody is fine.

    Here in Argentina and Chile have detected several clients that after migrating them to version 18.2.1 report problems sending emails to O365 domains.

    The error reported in the GWIA logs is 550 Host Unknown.

    After testing we have been able to detect that the GWIA uses TLS 1.0 regardless of the --sslOption that we use.
    If we make the GWIA relay via an AntiSpam, the emails arrive correctly at their destination, since the AntiSpam (MailCleaner, SMG, etc) has no problem using the new versions of TLS.

     

    wlucero_0-1592930632795.png

    Note: The minimum version accepted by O365 is 1.2.

    In the meantime, I just opened a SR.

    Bes regards.,

     

Children
No Data
Related Discussions
Recommended