GroupWise client on openSUSE 10.3

0 Likes
I need to precede this post with a bunch of disclaimers. This is not a supported configuration, it has not been tested by either GroupWise or SuSE engineering and I personally have not played with it enough to see if anything else is broken, however, it is possible to get the GroupWise client running on openSUSE 10.3.

When trying to install the RPM I got a number of libXm.so.3 dependency errors, so I installed:
openmotif-libs-32bit
openmotif-libs
openmotif22-libs-32bit
openmotif22-libs
openmotif

Probably overkill, but it installed after adding all of those. Oh, and I had first added a bunch of 'community repositories' which I think these were installing from.  Once installed the GroupWise client still does not launch.

The last thing that you need to do is to modify /opt/novell/groupwise/client/bin/groupwise.   On the line after the first export enter:
 export LIBXCB_ALLOW_SLOPPY_LOCK=1

The whole file now reads:
#!/bin/bash
export LD_LIBRARY_PATH=/opt/novell/groupwise/client/lib:/opt/novell/groupwise/client/jre/lib/i386
export LIBXCB_ALLOW_SLOPPY_LOCK=1
/opt/novell/groupwise/client/bin/groupwise-bin "$@"

Save that file and launch the client again - it should now work.

Labels:

How To-Best Practice
Comment List
Anonymous
Parents Comment Children
No Data
Related Discussions
Recommended