printers show processing or stopped

Somehow my iprint server has crashed again. Some printers are working fine. Others are showing either stopped or processing. Error messages in messages show:
SMLoadModule: the iPrint Manager was not able to exec Gateway module /opt/novell/iprint/bin/iprintgw for Printer Agent Library-laser. Error (13 - Permission denied) returned while doing execl().

for at least one of the printers that show processing. Any new printer objects that I create show the same behaviour. ndsrepair shows no errors. Ive checked permissions on the iprint directorys and an ls -la shows avahi user and iprint group. If I do a chown iprint for a file, it still shows avahi. If I doe a uname iprint it comes back avahi. Im not sure if permissions has gotten hosed. Ive googled around and cant find anything. Server has 68 printers running and supports a couple hundred users. In short HELP.

ddh
  • Im also seeing the following in regards to printers that wont work: PSMLoadModule: the iPrint Manager was not able to exec Gateway module for each printer that is marked as stopped or processing.
  • I think Im getting closer to the problem. For some reason the iprintgw wont load when the ipsmd is loaded. I dont see any error messages, but do see a lime PSMLoadModule: the iPrint Manager was not able to exec Gateway module /opt/novell/iprint/bin/iprintgw for Printer Agent buslab-laser-463. Error (13 - Permission denied) returned while doing execl(). for different printers. I can manually load the gateway as root, and printers show idle or printing. Any ideas on this?
  • Getting closer. When the ipsmd loads and creates the pid file, the file is owned bythe group avahi. I can change the ownership and manually start the iprintgw and printers start working. avahi was the owner of the /var/opt/iprint/printmanager.psm/ files also. Im thinking about deleting that group and seeing if it starts correctly, but I would like to try and figure out how a reboot of the server on Friday (after being up 600 days) caused the permissions to get hosed. I did try to get the novell-kanaka installed on this server last fall and Im wondering if that had some effect on any of these issues. If I get this fixed, Ill post what I find. In the meantime if any experts have ideas Im still open.
  • On 08/14/2013 02:36 AM, ddhottinger wrote:
    >
    > Getting closer. When the ipsmd loads and creates the pid file, the file
    > is owned bythe group avahi. I can change the ownership and manually
    > start the iprintgw and printers start working. avahi was the owner of
    > the /var/opt/iprint/printmanager.psm/ files also. Im thinking about
    > deleting that group and seeing if it starts correctly, but I would like
    > to try and figure out how a reboot of the server on Friday (after being
    > up 600 days) caused the permissions to get hosed. I did try to get the
    > novell-kanaka installed on this server last fall and Im wondering if
    > that had some effect on any of these issues. If I get this fixed, Ill
    > post what I find. In the meantime if any experts have ideas Im still
    > open.
    >
    >



    check ownership and permissions as tid7002678 shows. Execute what tid
    advice to put back the default and correct permissions