Print Manager Won't Start

Hello,

So I got the driver store created and have tried to create the print manager. I get it created in iManager but it will not start, at least not according to iManager. The command line says it is running:

ipsmd is running: CN=iPrintManager,OU=iPRINT,OU=PRINTERS,OU=CHI,OU=IL,O=HCSC

But in iManager it says it is down. Here is what I see in /var/log/messages:

Jun 30 12:12:45 dvoescl1n3 ipsmd[5078]: Error (506D0201) occurred while creating the iPrint Manager database.
Jun 30 12:13:46 dvoescl1n3 ipsmd[5078]: The iPrint Manager has unloaded successf ully.
Jun 30 12:13:46 dvoescl1n3 ipsmd[3357]: The iPrint Manager has just experienced a segfault or fatal error. It will be restarted by its monitor process.
Jun 30 12:13:46 dvoescl1n3 ipsmd[5760]: Error (506D0201) occurred while creating the iPrint Manager database.
Jun 30 12:14:48 dvoescl1n3 ipsmd[5760]: The iPrint Manager has unloaded successf ully.
Jun 30 12:14:48 dvoescl1n3 ipsmd[3357]: The iPrint Manager has just experienced a segfault or fatal error. It will be restarted by its monitor process.
Jun 30 12:14:48 dvoescl1n3 ipsmd[6481]: Error (506D0201) occurred while creating the iPrint Manager database.
Jun 30 12:15:49 dvoescl1n3 ipsmd[6481]: The iPrint Manager has unloaded successf ully.
Jun 30 12:15:49 dvoescl1n3 ipsmd[3357]: The iPrint Manager has segfaulted or had a fatal error and has been auto-restarted 5 times within the last hour. There a ppears to be a repetitive problem occurring. The iPrint Manager is exiting.
Jun 30 12:15:49 dvoescl1n3 kernel: ipsmd[3357]: segfault at 0000000000000008 rip 00002ab94eb9839d rsp 00007fff5c3adbe8 error 4

Any suggestions?

Thanks
Scott
  • Your print manager actually crashed. What OES version are you using and is
    your server fully patched? There were in fact some manager crash issues
    that have been fixed in newer updates.

    --
    Marcel Cox
    http://support.novell.com/forums
    ------------------------------------------------------------------------
    Marcel Cox's Profile: http://forums.novell.com/member.php?userid=8
  • The server is Sles10sp2/Oes2sp1 64bit. I patched it yesterday with the latest patches from Novell. So it is up to date. So since I patched it yesterday I figured I would start from scratch so I deleted the print manager and the driver store that I had created and created new ones. The driver store starts properly but the manager still will not load properly and in fact does not stay loaded.

    Jul 2 08:57:04 dvoescl1n3 ipsmd[12660]: iPrint Manager 'PrintManager.iPRINT.PRINTERS.CHI.IL.HCSC' has started loading.
    Jul 2 08:57:04 dvoescl1n3 ipsmd[12667]: Error (506D0203) occurred while initializing the Managed Object database.
    Jul 2 08:58:05 dvoescl1n3 ipsmd[12667]: The iPrint Manager has unloaded successfully.
    Jul 2 08:58:05 dvoescl1n3 ipsmd[12664]: The iPrint Manager has just experienced a segfault or fatal error. It will be restarted by its monitor process.
    Jul 2 08:58:06 dvoescl1n3 ipsmd[13322]: Error (506D0203) occurred while initializing the Managed Object database.

    I have created the driver store and print manager on a cluster resource. I used the ip address of the cluster resource instead of the host name. The cluster resource is up and running. The version of iManager I am using is 2.7.3. It is running on the same version of Sles10 and OES2 and has the same patches installed.

    I am doing this because I want to go through the process of migrating iPrint on Netware to iPrint on Linux but I cannot even get iPrint on Linux to work.

    Any suggestions?

    Thanks
    Scott
  • So iPrint is running on a cluster. In this case, check the following:

    http://www.novell.com/documentation/oes2/iprint_lx/data/sec_iprintcluster_troubleshooting.html

    --
    Marcel Cox
    http://support.novell.com/forums
    ------------------------------------------------------------------------
    Marcel Cox's Profile: http://forums.novell.com/member.php?userid=8
  • Thanks for the info and that explains the error but in that same documentation it says that you can run iPrint on NSS hence the iprint_nss_relocate command so maybe I have to install it first on the Linux file system? Why was I able to setup the driver store on the clustered nss volume?

    Thanks
    Scott
  • Thanks for the info and that explains the error but in that same documentation it says that you can run iPrint on NSS hence the iprint_nss_relocate command so maybe I have to install it first on the Linux file system? Why was I able to setup the driver store on the clustered nss volume?

    Thanks
    Scott
  • SJFast911 wrote:
    > Thanks for the info and that explains the error but in that same
    > documentation it says that you can run iPrint on NSS hence the
    > iprint_nss_relocate command so maybe I have to install it first on the
    > Linux file system? Why was I able to setup the driver store on the
    > clustered nss volume?
    >
    > Thanks
    > Scott
    >
    >


    You can configure and move it and the better option would be to run the
    script and configure it after moving it to NSS. The script does work in
    both the cases.

    It could be because the permission are not given to the right locations
    on the NSS volume for the necessary lum objects like iPrint, wwwrun,
    www, etc. But still it should not have segfaulted.

    Can you attach from the location /var/opt/novell/log the following
    files, from both or all the nodes ?

    iprint_nss_relocate.log
    iprint_relocate.err

    There have been a few fixes in that script, which will be included in a
    patch release. You can contact Novell support to get that.

    Regards,