Client for Windows - inplace upgrade from Win 7 64-bit to Windows 10-bit

Not sure if this is still the case, but here goes:


Eons ago, I had a Windows 7 64-bit laptop with the Novell client on it.

I in-place upgraded to Windows 10 (64-bit) and I vaguely recall that the Novell client did not work and had to then be manually uninstalled and then either reinstalled, or the Windows 10 "version" installed.


1) Is that still the case?

2) We have like 1,200 Windows 7 64-bit machines that the powers that be want to in-place upgrade (NOT re-image) to Windows 10, so I'm wondering what the "best" way to do whilst dealing with the Client.  Try to have a script the uninstalls the client, does the upgrade and then installs the new version?



  • In place upgrade?  Ouch.  I've made it a practice to never do that with Windows.  However, I can say that I am using the exact same OES client for both Win7 and Win10.  I would think it would work, but I wouldn't be surprised if Microsoft does some things during the upgrade that break the client.  So unless someone else that has tried it jumps in with their experience, I would say test it and let us know what you find out.  But then you know that. 

  • Verified Answer

    It's been awhile since I did inplace upgrades from Windows 7 with oes client installed, but I don't recall any problem with the oes client after the upgrade, at least not with the last bunch I did 2-3 years ago.  The client is exactly the same for 7 & 10.  There was a problem with one of the windows 10 version upgrades, think it might have been 1607 or 1703 where the client would lose all it's settings, but that's been fixed long ago.

    Test a couple of upgrades with the latest OES client installed, I think you'll find it works fine.

    (actually now I recall I did an in-place upgrade from 7 to 10v1803 within the last 9 months at most, and I know I didn't have to do anything at all with the OES client, it just worked)


  • We'll try the in-place upgrade and see what happens.

    Using Client 2 SP3 on most machines.

    I think when I'd tried it at home I was using build 1603 when it failed.

  • I wouldn't recommend trying it with Client 2 SP3 installed.  That's really, really old, and I can just about guarantee it won't work with Windows 10 at all (in fact I'm not altogether sure SP3 is even officially supported for Windows 7; SP4 has been out for a LONG time).  I'm pretty sure some of the changes that let an in-place upgrade work now are in the client, while others are in the Windows installation.

    Upgrade to the latest Client 2 (SP4 IR12 as I type) first.  If you don't have a mechanism in place to update the client, fix that now.


  • Thanks, I'll see about doing that.

  • btw, it was 10v1703 that has the problem with losing all the oes client settings during the upgrade.  That was never fixed, but presumably you won't be installing 1703.  Other versions don't have the problem.

  • Just an FYI:

    Tried with Client2 SP3 - worked fine/beautifully, no issues at all.

    Also used the client update/autoupdate (whatever the option is) and updated to Client for Open Enterprise Server 2 SP4 (IR11) and then OS upgraded.  Also went fine.

  • Glad it to hear it worked for you.  I'm surprised it worked with Client 2 SP3, guess that shows it's a lot less dependent on the client version than I thought.  Obviously best to upgrade anyway of course.