file access issues from windows 10/ 2016/ 2019

Hi,

have faced a problem when trying to access files on OES2015 server. The folder is opening fine, but when trying to open or copy files the window became unresponsive for 2-3 minutes, then the error displayed "The request is not supported". Second try opens file without delay.

It happening on windows 10, windows server 2016, 2019 with all known versions of Client for OES starting from freshest one. Tested same files from windows server 2003/2008 revealed no problems.

Tried different options like File Caching, File Commit gave no results, as well solution from TID 7002232.

Any help is highly appreciated.

  • Couple remarks.

    Noticed the problem happens with big files (10M ). Small files are opening without delays.

    After the error displayed/closed you can work fine with the files in current folder. But when you go to another directory  and come back the problem repeats.

  • One more remark

    Just tested on NetWare 6.5 server. The problem is not revealed. So this is OES2015 NSS volume specific.

  • There are lots of potential reasons for such a behaviour. A trace would likely show what's really going on. While i'd always start with uninstalling (not just disabling) AV, there's a known issue which has been fixed AGES ago. Nevertheless, if it's really OES2015 (as opposed to OES2015SP1) and if it hasn't been patched for a LOOOOONG time, you might want to try the following to check whether you're affected by this issue.
    On a box with client revision SP4IR2 or higher create reg setting named "DisableLargeNCPReadWrite" underneath
    HKLM\Software\Novell\Client\Parameters
    and give it a value of 1. Reboot the the box and check again.
    Note that if it's about this particular issue, you'd never see it on a box running XP / 2003 and you'd never see it on anything newer running a client up to version 2 SP3IR10b as the NCP verbs involved (87,72 and 87,73) were introduced with SP4.

  • Hi Mathias, thanks for your advice.

    AV was uninstalled before. Tried "DisableLargeNCPReadWrite", but no success. This is really OES2015 server, planning to update it to OES2015 SP1 on Monday. Will revert with the outcome.

     

    Regards,
    Michael

  • The problem resolved after updating to OES2015 SP1.

     thanks for helping!