OES2018 upgrade hangs, can't complete

I attempted to upgrade my GroupWise 18 server from OES2015SP1 to OES2018; I'd like to upgrade Messenger, which also runs on that server, to the new version 18, but it requires SLES12/OES2018.

It goes through the first part of the install fine, but then hangs on the EDirectory upgrade section. It gets to 100% on the progress bar, with all items checked off. The last item, "Configuring NMAS Login Methods" still shows above the progress bar, but is checked off in the list. At this point the mouse cursor is an arrow with a spinning wheel, the Next button is greyed out, while the Abort and Help buttons do nothing.

I tried twice with the same result. Both times I left it to run for over an hour. I couldn't find any error message on any of the consoles that was illuminating.

It got to be bedtime, so I gave in and rolled back to the VM snapshot I took before starting. As per the glorious magic of snapshots, the server booted back up like nothing had happened.

Any suggestions to where to look if I try this again? Should I just wait for OES2018SP1?