Unable to ping resource record


I have created a new server. I want to add this server to the DNS server which is running op SLES 10 SP3 OES 2 SP3.
I have used iManager to add the resource record with its associated PTR record.
I can't resolve the name of the new server. I have restarted novell-named a few times but still doesn't work. I have also tried the DNS-DHCP console to add the record.
The record is being created but does not resolve.
I have also run ndsrepair -U and no error's were found. It is running on vmware ESXi 5.1 with 2 virtual cpu's.
I have also tried /opt/novell/named/bin/novell-named -u named -n 1 but also no result.

What could be the problem of this issue?

  • One possible reason you could experience this is if you are experiencing ldap communication failures between the server and eDirectory. Changes made in eDir may not be syncing with the local servers via the restart or the dynamic reconfig. You can test this by doing the following:
    cd /etc/opt/novell/named; mkdir OLD; mv *db OLD; mv *jnl OLD; rcnovell-named restart

    If the db files are recreated after the restart (may take 20-30 seconds or so) then you are fine and that isn't your issue. If they are not being recreated then you found where your issue resides and where to focus your attention.