HP FibreChannel HBA on SLES/OES

Hopefully this is the right forum.

Has anyone been able to install the hba and drivers for an HP 81B?
It's a 1 port FC HBA from Brocade.
I'm running in circles trying to get it installed and recognized under
OES 11 SP1, so I was wondering if someone has the "trick" to get it going.

TIA
Parents
  • Jose Mugica;2256018 wrote:
    Hopefully this is the right forum.

    Has anyone been able to install the hba and drivers for an HP 81B?
    It's a 1 port FC HBA from Brocade.
    I'm running in circles trying to get it installed and recognized under
    OES 11 SP1, so I was wondering if someone has the "trick" to get it going.

    TIA


    without further knowledge of this adapter (qlogic all the way, maybe emulex on bad days :-) ) i'd assume that the shipping driver (i.e. the one which comes with SLES11SP2) doesn't recognize the adapter. vendors tend to change device IDs for new revisions (whilst keeping the "friendly name"), so an older driver would have to guess...


    the driver should be named "bfa", the one which comes with SLES has version 3.0.2.2 (modinfo bfa |grep version). if this is what you currently have you might want to try version 3.1.0.0 which is the current one for HP-branded brocade HBAs.
Reply
  • Jose Mugica;2256018 wrote:
    Hopefully this is the right forum.

    Has anyone been able to install the hba and drivers for an HP 81B?
    It's a 1 port FC HBA from Brocade.
    I'm running in circles trying to get it installed and recognized under
    OES 11 SP1, so I was wondering if someone has the "trick" to get it going.

    TIA


    without further knowledge of this adapter (qlogic all the way, maybe emulex on bad days :-) ) i'd assume that the shipping driver (i.e. the one which comes with SLES11SP2) doesn't recognize the adapter. vendors tend to change device IDs for new revisions (whilst keeping the "friendly name"), so an older driver would have to guess...


    the driver should be named "bfa", the one which comes with SLES has version 3.0.2.2 (modinfo bfa |grep version). if this is what you currently have you might want to try version 3.1.0.0 which is the current one for HP-branded brocade HBAs.
Children
  • Thanks, it seems I'm already running version 3.1.0.0 from Brocade.
    Any other software from HP that I need to run to see the drives in the SAN?
    I'm going to take a look at the configuration of the SAN, but I wanted
    to make sure that I don't need anything else on the server side. I was
    hoping to see the hba inside partitioner and I don't.

    Jose

    On 4/4/2013 7:06 AM, mathiasbraun wrote:
    >
    > Jose Mugica;2256018 Wrote:
    >> Hopefully this is the right forum.
    >>
    >> Has anyone been able to install the hba and drivers for an HP 81B?
    >> It's a 1 port FC HBA from Brocade.
    >> I'm running in circles trying to get it installed and recognized under
    >> OES 11 SP1, so I was wondering if someone has the "trick" to get it
    >> going.
    >>
    >> TIA

    >
    > without further knowledge of this adapter (qlogic all the way, maybe
    > emulex on bad days :-) ) i'd assume that the shipping driver (i.e. the
    > one which comes with SLES11SP2) doesn't recognize the adapter. vendors
    > tend to change device IDs for new revisions (whilst keeping the
    > "friendly name"), so an older driver would have to guess...
    >
    >
    > the driver should be named "bfa", the one which comes with SLES has
    > version 3.0.2.2 (modinfo bfa |grep version). if this is what you
    > currently have you might want to try version 3.1.0.0 which is the
    > current one for HP-branded brocade HBAs.
    >
    >

  • Nevermind, I just found out connecting the Brocade HBA directly to the
    HP P2000G3 doesn't work, you have to use an FC switch.

    Jose

    On 4/4/2013 7:06 AM, mathiasbraun wrote:
    >
    > Jose Mugica;2256018 Wrote:
    >> Hopefully this is the right forum.
    >>
    >> Has anyone been able to install the hba and drivers for an HP 81B?
    >> It's a 1 port FC HBA from Brocade.
    >> I'm running in circles trying to get it installed and recognized under
    >> OES 11 SP1, so I was wondering if someone has the "trick" to get it
    >> going.
    >>
    >> TIA

    >
    > without further knowledge of this adapter (qlogic all the way, maybe
    > emulex on bad days :-) ) i'd assume that the shipping driver (i.e. the
    > one which comes with SLES11SP2) doesn't recognize the adapter. vendors
    > tend to change device IDs for new revisions (whilst keeping the
    > "friendly name"), so an older driver would have to guess...
    >
    >
    > the driver should be named "bfa", the one which comes with SLES has
    > version 3.0.2.2 (modinfo bfa |grep version). if this is what you
    > currently have you might want to try version 3.1.0.0 which is the
    > current one for HP-branded brocade HBAs.
    >
    >