Cluster backup and failed over resource still listed in mounts and mtab


I'm running a OES Linux sp2 iSCSI cluster (latest patches). When a
clustered NSS volume fails over from node 1 to node 2 then the mount
information of the resource is still listed in /proc/mounts and
/etc/mtab on node 1. I ran into this when using my clustered backup
solusion (SEP Sesam) and tried to backup a certain cluster resource. I
gat an error starting the job about that a volume that's in mtab is
not availabe on the node that the resource runs that I am to backup.
The strange thing is that another resource on that same node can be
backuped withoutany problems.

To be more clear what happened:
Node 1 runs the resources: APS, USR, MAIL
Node 2 runs the resources: IMG, SPOOL

The resources have been running on both nodes for the last weeks, so
when I did look at mtab or /proc/mounts for both nodes all resources
are listed as:
SPOOL on /media/nss/SPOOL type nssvol (rw,name=SPOOL)
IMG on /media/nss/IMG type nssvol (rw,name=IMG)
USR on /media/nss/USR type nssvol (rw,name=USR)
MAIL on /media/nss/MAIL type nssvol (rw,name=MAIL)
APS on /media/nss/APS type nssvol (rw,name=APS)

Now I could backup MAIL withoud any problems, but backing up APS or
USR complained about that SPOOL listed in mtab on node 1 was not
mounted on node 1. When I move SPOOL back to node 1 the problem was

I yesterday rebooted node 1 and now node 1 only lists APS, USR and
MAIL in mtab and /proc/mounts. Node 2 ran, while rebooting node 1, of
course APS USR and MAIL for a while and after moving them back to node
1 mtab and /etc/proc on node 2 still list them as being mounted.

As I think it should be /proc/mounts should only list what's mounted
on a server. The mtab could be 'out of sync' as stated in the SLES
manuals. Is this working as designed or might this be a problem in the
way OES dismount clustered volume (and does not inform the kernel
(process) correctly?

Any suggestions are (of course<G>) welcome!


Sebastiaan Veld
Wannit BV