Remove IP Address From Server

Hello,

I have 4 Netware 6.5, SP8 servers that were configured similarly - each one has 2 NIC's, 1 with an address on 192.168.100.x subnet and the other with an address on 192.168.200.x subnet - I had workstations on both subnets and they were able to talk to each other... what I've done now is to remove the 200.x NIC's and now I use VLAN's and IP routing to get the job done - my servers are on a VLAN using the 100.x subnet and my workstations are on another VLAN using the 200.x subnet - the workstations can ping and most of them can connect...

One of my Netware servers was doing DHCP for both subnets - I've disabled that and am now using a Win2K8 server for DHCP - it gives out IP addresses based on the VLAN the machine requesting them is on

My problem is the some of my workstations cannot login, they cannot find the tree. These machines are getting IP addresses just fine, just like they are supposed to - but I cannot do anything to make them see the tree -

Is there an IP setting I'm missing - is there something I should check on the servers after removing the second IP address from each server?

Thanks!!
  • When eDirectory starts on the server, it will enumerate the NCP transport endpoints and publish them in the server's Network Address field. You can see this in Console One by looking at the details of the server's NCP Server Object. If the Network Address field still contains the defunct addresses, you can reboot the server, or restart eDirectory via SET DSTRACE =*. ( That's "star dot" ) This should force the update of the network address field. You can confirm after a few minutes in Console One. Then when workstations say "Hey, how do I get to server FOO?" It will get a correct answer.

    As to the rest? I don't know. Its likely your NetWare DHCP server was handing out SLP / TREE / ... options which the client was using to locate the server. Try entering the IP address of the netware server in the TREE field and see if you can login. If so, its a SLP issue.

    Other options are that the server is still trying to route traffic out the missing IP address / interface. Check the routing configuration using INETCFG and TCPCON.

    Lots of ways it ould be broken, you are just going to have to eliminate as many of them as possible. The risk of changing too many things simultaneously should not be underestimated. I would have opted to move the DHCP server over, and left the IP addresses on the servers. Then once you have confirmed proepr operation of DHCP, then decommission the IP addresses.

    -- Bob
  • On Thu, 19 Jan 2012 04:56:04 0000, Bob-O-Rama wrote:

    > When eDirectory starts on the server, it will enumerate the NCP
    > transport endpoints and publish them in the server's Network Address
    > field.


    This is done by the LIMBER process, and happens periodically as well.
    Every 12 hours, if I recall correctly.


    > You can see this in Console One by looking at the details of
    > the server's NCP Server Object. If the Network Address field still
    > contains the defunct addresses, you can reboot the server, or restart
    > eDirectory via *SET DSTRACE =*.* ( That's "star dot" )


    Somewhere around NDS7, the "*." idea was deprecated. Please use "unload
    ds" and "load ds" instead. This will cause LIMBER to be run, and will
    also cause the server to re-register with the configured SLP DAs.

    I'd be inclined to guess that the problem is actually the SLP
    registration is wrong.


    --
    --------------------------------------------------------------------------
    David Gersic dgersic_@_niu.edu
    Knowledge Partner http://forums.novell.com

    Please post questions in the forums. No support provided via email.

  • Hi.

    On 19.01.2012 17:00, David Gersic wrote:
    > I'd be inclined to guess that the problem is actually the SLP
    > registration is wrong.


    I'd be inclined to guess that there is no proper SLP configuration at
    all, and it just worked before, because servers and workstations were in
    the same segment. ;)

    CU,
    --
    Massimo Rosen
    Novell Knowledge Partner
    No emails please!
    http://www.cfc-it.de