Novell Client 2 SP3 on Windows7 - bypassing autoadminlogon

I have workstations with Windows 7 Professional SP1 and Novell Client 2 SP3 in school pc room.

- students have to login Netware with their username and password
- next they are automatically logged to Windows 7 using one username for all users and no
password with basic rights

All seems fine until I want to make some changes on workstation which need administrative rights.
On Windows XP pressing SHIFT key during boot or logout cause windows logon screen to appear after successful login to Netware.
On Windows 7 this method doesn't work and after Netware authentication Windows 7 autoadminlogon user is logged.

When I tried to disable Novell Client on workstation, bypassing autoadminlogon via SHIFT key works fine.

Any idea what should be wrong?
Thanks.
  • bossacek,

    on the Novell login screen, there's an option "Computer only" or some such right beneath the Forgotten Password link.
    Is that what you are looking for?

    Uwe

    --
    Novell Knowledge Partner
    Please don't send me support related e-mail unless I ask you to do so.
  • Yes, it's way I'm using now to log in as administrator.
    But I would like to clear password for common windows user and still disable access to students without novell authentication.
    So I'm planning to disable "Computer only" option in Novell login screen.

    buckesfeld;2375720 wrote:
    bossacek,

    on the Novell login screen, there's an option "Computer only" or some such right beneath the Forgotten Password link.
    Is that what you are looking for?

    Uwe

    --
    Novell Knowledge Partner
    Please don't send me support related e-mail unless I ask you to do so.
  • bossacek,

    I'm not sure I understand what you need.
    When you press END when the Windows login starts, it should disable the Novell login. Not sure if it presents you with a Windows logon dialog or if it triggers the Windows auto logon.

    Question: Why do you need to logon as administrator anyway? Normally Windows UAC asks for admin credentials if necessary, or you can right click apps and run as administrator.

    Uwe

    --
    Novell Knowledge Partner
    Please don't send me support related e-mail unless I ask you to do so.
  • Thanks for your response.

    Pressing END disable Novell login but Windows process auto logon. It's not good for me because students should bypass Novell login by this way too and they should use computer without authentication.

    I know about possibility to run program as administrator but some settings in control panel are disabled for "standard user" at all.

    I want to be able force administrator login in special cases of system configuration. Students should be using standard user account.
    If I use password for this standard user and for windows auto login store it in registry, handy student should read registry a get password. Then he will be able to use computer (due option "Computer only").
    If I use standard user without password I need to disable option "Computer only" and have ability to bypass auto logon of this standard user to logon as asministrator.

    buckesfeld;2375873 wrote:
    bossacek,

    I'm not sure I understand what you need.
    When you press END when the Windows login starts, it should disable the Novell login. Not sure if it presents you with a Windows logon dialog or if it triggers the Windows auto logon.

    Question: Why do you need to logon as administrator anyway? Normally Windows UAC asks for admin credentials if necessary, or you can right click apps and run as administrator.

    Uwe

    --
    Novell Knowledge Partner
    Please don't send me support related e-mail unless I ask you to do so.
  • Hi,

    On the workstation right-click on the red N in the system tray and select the last option on the menu to go to the Properties of the Novell client. On the Advanced Login tab scroll down and find the following option "Prompt for Novell login during Windows AutoAdminLogon". By default this setting is OFF. Perhaps this is what you are looking for?

    Cheers,
  • Hi.

    I have "Prompt for Novell login during Windows AutoAdminLogon"=ON. But pressing END during boot will disable Novell login anyway.

    laurabuckley;2376267 wrote:
    Hi,

    On the workstation right-click on the red N in the system tray and select the last option on the menu to go to the Properties of the Novell client. On the Advanced Login tab scroll down and find the following option "Prompt for Novell login during Windows AutoAdminLogon". By default this setting is OFF. Perhaps this is what you are looking for?

    Cheers,
  • Hi

    Are you aware that with auto admin login enabled if the standard user's eDirectory password is the same as the local Windows password the password does not need to be stored in the registry. Likewise with your Admin account. That way a clever standard user can't get your password out of the registry.

    Cheers,