admin password change not working

I tried to change my password

ifolderesx01:~ # /usr/bin/mono /usr/lib64/simias/bin/UserCmd.exe setpwd --url https://localhost --admin-name admin --admin-password OLDPASSWD --user admin --password NEWPASSWD
Failed - Invalid admin credentials

I am able to login to the /admin url without any problems.

:~ # wget https://localhost --no-check-certificate
--2011-03-22 09:53:04-- https://localhost/
Resolving localhost... ::1, 127.0.0.1
Connecting to localhost|::1|:443... connected.
WARNING: cannot verify localhost's certificate, issued by `/C=XY/ST=unknown/L=unknown/O=SuSE Linux Web Server/OU=CA/CN=FQDN/emailAddress=xxx@xxx':
Unable to locally verify the issuer's authority.
WARNING: certificate common name `FQDN' doesn't match requested host name `localhost'.
HTTP request sent, awaiting response... 403 Forbidden
2011-03-22 09:53:04 ERROR 403: Forbidden.

:~ # wget http://localhost
--2011-03-22 09:53:10-- http://localhost/
Resolving localhost... ::1, 127.0.0.1
Connecting to localhost|::1|:80... connected.
HTTP request sent, awaiting response... 403 Forbidden
2011-03-22 09:53:10 ERROR 403: Forbidden.


ifolderesx01:~ # cat /ifolder/simias/data/simias/Simias.config
<configuration>
<section name="EnterpriseDomain">
<setting name="SystemName" value="iFolder" />
<setting name="Description" value="iFolder Enterprise System" />
<setting name="AdminName" value="admin" />
<setting name="AdminPassword" value="xxx" />
</section>
<section name="Server">
<setting name="Name" value="ifolderesx01.xxx" />
<setting name="MultiByteServer" value="yes" />
<setting name="PublicAddress" value="">https://10.145.5.46/simias10" />
<setting name="PrivateAddress" value="">https://10.145.5.46/simias10" />
<setting name="RAPath" value="/ifolder/simias/data/" />
</section>
<section name="Authentication">
<setting name="SimiasAuthNotRequired" value="Registration.asmx, Login.ashx, Simias.asmx:PingSimias, DomainService.asmx:GetDomainID, pubrss.ashx, pubsfile.ashx, Simias.asmx:GetRAList, Simias.asmx:GetRACertificate, iFolderBackup.asmx:GetSimiasDataPath, iFolderBackup.asmx:Ping, iFolderAdmin.asmx:GetProxyInfo" />
<setting name="SimiasRequireSSL" value="yes" />
</section>
<section name="Identity">
<setting name="Assembly" value="Simias.Server" />
<setting name="ServiceAssembly" value="Simias.Server" />
<setting name="Class" value="Simias.Server.InternalUser" />
<setting name="LdapSyncOnRestart" value="No" />
<!--
<setting name="Assembly" value="Simias.SimpleServer" />
<setting name="Class" value="Simias.SimpleServer.User" />
-->
<!--
<setting name="Assembly" value="Simias.MdbSync" />
<setting name="Class" value="Simias.MdbSync.User" />
-->
</section>
<section name="StoreProvider">
<setting name="CommonProxyLogPath" value="/var/opt/novell/log/proxymgmt/pxymgmt.log" />
<setting name="Assembly" value="SimiasLib.dll" />
<setting name="Type" value="Simias.Storage.Provider.Flaim.FlaimProvider" />
<setting name="Path" value="/ifolder/simias/data/simias" />
</section>

Tags:

  • dskjelmose;2088244 wrote:
    I tried to change my password

    ifolderesx01:~ # /usr/bin/mono /usr/lib64/simias/bin/UserCmd.exe setpwd --url https://localhost --admin-name admin --admin-password OLDPASSWD --user admin --password NEWPASSWD
    Failed - Invalid admin credentials

    I am able to login to the /admin url without any problems.

    :~ # wget https://localhost --no-check-certificate
    --2011-03-22 09:53:04-- https://localhost/
    Resolving localhost... ::1, 127.0.0.1
    Connecting to localhost|::1|:443... connected.
    WARNING: cannot verify localhost's certificate, issued by `/C=XY/ST=unknown/L=unknown/O=SuSE Linux Web Server/OU=CA/CN=FQDN/emailAddress=xxx@xxx':
    Unable to locally verify the issuer's authority.
    WARNING: certificate common name `FQDN' doesn't match requested host name `localhost'.
    HTTP request sent, awaiting response... 403 Forbidden
    2011-03-22 09:53:04 ERROR 403: Forbidden.

    :~ # wget http://localhost
    --2011-03-22 09:53:10-- http://localhost/
    Resolving localhost... ::1, 127.0.0.1
    Connecting to localhost|::1|:80... connected.
    HTTP request sent, awaiting response... 403 Forbidden
    2011-03-22 09:53:10 ERROR 403: Forbidden.


    ifolderesx01:~ # cat /ifolder/simias/data/simias/Simias.config
    <configuration>
    <section name="EnterpriseDomain">
    <setting name="SystemName" value="iFolder" />
    <setting name="Description" value="iFolder Enterprise System" />
    <setting name="AdminName" value="admin" />
    <setting name="AdminPassword" value="xxx" />
    </section>
    <section name="Server">
    <setting name="Name" value="ifolderesx01.xxx" />
    <setting name="MultiByteServer" value="yes" />
    <setting name="PublicAddress" value="">https://10.145.5.46/simias10" />
    <setting name="PrivateAddress" value="">https://10.145.5.46/simias10" />
    <setting name="RAPath" value="/ifolder/simias/data/" />
    </section>
    <section name="Authentication">
    <setting name="SimiasAuthNotRequired" value="Registration.asmx, Login.ashx, Simias.asmx:PingSimias, DomainService.asmx:GetDomainID, pubrss.ashx, pubsfile.ashx, Simias.asmx:GetRAList, Simias.asmx:GetRACertificate, iFolderBackup.asmx:GetSimiasDataPath, iFolderBackup.asmx:Ping, iFolderAdmin.asmx:GetProxyInfo" />
    <setting name="SimiasRequireSSL" value="yes" />
    </section>
    <section name="Identity">
    <setting name="Assembly" value="Simias.Server" />
    <setting name="ServiceAssembly" value="Simias.Server" />
    <setting name="Class" value="Simias.Server.InternalUser" />
    <setting name="LdapSyncOnRestart" value="No" />
    <!--
    <setting name="Assembly" value="Simias.SimpleServer" />
    <setting name="Class" value="Simias.SimpleServer.User" />
    -->
    <!--
    <setting name="Assembly" value="Simias.MdbSync" />
    <setting name="Class" value="Simias.MdbSync.User" />
    -->
    </section>
    <section name="StoreProvider">
    <setting name="CommonProxyLogPath" value="/var/opt/novell/log/proxymgmt/pxymgmt.log" />
    <setting name="Assembly" value="SimiasLib.dll" />
    <setting name="Type" value="Simias.Storage.Provider.Flaim.FlaimProvider" />
    <setting name="Path" value="/ifolder/simias/data/simias" />
    </section>


    Try changing https://localhost to your FQDN of your iFolder server (Example: https://your.ifolderserver.com or http://your.ifolderserver.com or http://localhost) in the command and see if it solves the issue.

    Thomas
  • dskjelmose;2088244 wrote:
    I tried to change my password

    ifolderesx01:~ # /usr/bin/mono /usr/lib64/simias/bin/UserCmd.exe setpwd --url https://localhost --admin-name admin --admin-password OLDPASSWD --user admin --password NEWPASSWD
    Failed - Invalid admin credentials

    I am able to login to the /admin url without any problems.

    :~ # wget https://localhost --no-check-certificate
    --2011-03-22 09:53:04-- https://localhost/
    Resolving localhost... ::1, 127.0.0.1
    Connecting to localhost|::1|:443... connected.
    WARNING: cannot verify localhost's certificate, issued by `/C=XY/ST=unknown/L=unknown/O=SuSE Linux Web Server/OU=CA/CN=FQDN/emailAddress=xxx@xxx':
    Unable to locally verify the issuer's authority.
    WARNING: certificate common name `FQDN' doesn't match requested host name `localhost'.
    HTTP request sent, awaiting response... 403 Forbidden
    2011-03-22 09:53:04 ERROR 403: Forbidden.

    :~ # wget http://localhost
    --2011-03-22 09:53:10-- http://localhost/
    Resolving localhost... ::1, 127.0.0.1
    Connecting to localhost|::1|:80... connected.
    HTTP request sent, awaiting response... 403 Forbidden
    2011-03-22 09:53:10 ERROR 403: Forbidden.


    ifolderesx01:~ # cat /ifolder/simias/data/simias/Simias.config
    <configuration>
    <section name="EnterpriseDomain">
    <setting name="SystemName" value="iFolder" />
    <setting name="Description" value="iFolder Enterprise System" />
    <setting name="AdminName" value="admin" />
    <setting name="AdminPassword" value="xxx" />
    </section>
    <section name="Server">
    <setting name="Name" value="ifolderesx01.xxx" />
    <setting name="MultiByteServer" value="yes" />
    <setting name="PublicAddress" value="">https://10.145.5.46/simias10" />
    <setting name="PrivateAddress" value="">https://10.145.5.46/simias10" />
    <setting name="RAPath" value="/ifolder/simias/data/" />
    </section>
    <section name="Authentication">
    <setting name="SimiasAuthNotRequired" value="Registration.asmx, Login.ashx, Simias.asmx:PingSimias, DomainService.asmx:GetDomainID, pubrss.ashx, pubsfile.ashx, Simias.asmx:GetRAList, Simias.asmx:GetRACertificate, iFolderBackup.asmx:GetSimiasDataPath, iFolderBackup.asmx:Ping, iFolderAdmin.asmx:GetProxyInfo" />
    <setting name="SimiasRequireSSL" value="yes" />
    </section>
    <section name="Identity">
    <setting name="Assembly" value="Simias.Server" />
    <setting name="ServiceAssembly" value="Simias.Server" />
    <setting name="Class" value="Simias.Server.InternalUser" />
    <setting name="LdapSyncOnRestart" value="No" />
    <!--
    <setting name="Assembly" value="Simias.SimpleServer" />
    <setting name="Class" value="Simias.SimpleServer.User" />
    -->
    <!--
    <setting name="Assembly" value="Simias.MdbSync" />
    <setting name="Class" value="Simias.MdbSync.User" />
    -->
    </section>
    <section name="StoreProvider">
    <setting name="CommonProxyLogPath" value="/var/opt/novell/log/proxymgmt/pxymgmt.log" />
    <setting name="Assembly" value="SimiasLib.dll" />
    <setting name="Type" value="Simias.Storage.Provider.Flaim.FlaimProvider" />
    <setting name="Path" value="/ifolder/simias/data/simias" />
    </section>


    Try changing https://localhost to your FQDN of your iFolder server (Example: https://your.ifolderserver.com or http://your.ifolderserver.com or http://localhost) in the command and see if it solves the issue.

    Thomas
  • I tried with https://localhost, http://localhost, https://internalIP, http://internalIP, https://FQDN, http://FQDN but without any luck. I even tried booting the server :-)

    well I guess im screwed with the default password :-)
  • Okay, moved the old similas folder to *.old and did simias-server-setup and changed the password that way.