"Unable to create mobile account" error with existing users

Kanaka v 2.7.0.52
OS X 10.8.5
OES 11

Background:

I have random users that will receive the "Unable to create mobile account" error upon authentication through the Kanaka plugin. Kanaka logs show a successful authentication. The interesting part is that these users have successfully authenticated to the particular computer previously and already had a managed mobile account created at that time. It appears that their user account has been removed from the System Preferences -> Users
  • jqcampbell;2305731 wrote:
    Kanaka v 2.7.0.52
    OS X 10.8.5
    OES 11

    Background:

    I have random users that will receive the "Unable to create mobile account" error upon authentication through the Kanaka plugin. Kanaka logs show a successful authentication. The interesting part is that these users have successfully authenticated to the particular computer previously and already had a managed mobile account created at that time. It appears that their user account has been removed from the System Preferences -> Users
  • uberkind9;2307142 wrote:
    We also see this behavior a lot. No real explanation, but our troubleshooting workflow for it is:
    - Does the System Prefs - Users window crash when accessing it? If so, try dscl...
    - Does dscl . --delete /Users/username throw an error? If so, reimage the machine...

    If the dscl deletion works, we don't even rename the home directory, and a subsequent login is usually successful.

    If you find any definitive reason why this happens, please share!


    I have listed the accounts via command line using the dscl command to see if it existed there and just not in the GUI. In most cases the user will not appear in the list and therefore fails out with an incorrect path when you attempt to delete it in the manner you describe. When I looked in the console of a particular iMac it showed the attempt to create the account using MCXCCreateMobileAccount, but it fails stating "Could not create the record because one already exists with the same name." This sent me on a search to find some other location that user account information is cached. I've had difficulty locating or clearing any remaining portions of this "seemingly" deleted account.

    We did find that a system update (10.8.4 to 10.8.5) seemed to clear this cached user information and allowed the users to login once again. This has only been a temporary fix and we are now seeing users experiencing this issue once again. I'm not sure what would cause Kanaka to initiate the deletion of an existing mobile user account. I am trying to isolate specific users and see if there is something changing with their account in e-directory that could possibly cause Kanaka to interpret their information differently. I'm not sure if it's possible, but it may be changing their local mobile account to a network account which deletes incompletely at logout and prevents the creation of the new account upon their next login. I still don't understand the root of what would initiate that through e-directory or Kanaka.

    One difference that I am beginning to see with our student user accounts has to do with the naming of their user folders on the mac. The user folders are typically named "s123456" with a lowercase s and their student ID number. I have noticed recently that there are several folders that are being created with a capital S versus lowercase. I know that Novell typically does not care about case, but I believe that the mac may be sensitive to this type of change.

    Forgot to add this initially... We do not experience System Preference crashes when accessing Users.
  • I was also curious what version of Kanaka you are running?
  • We too have been experiencing the same issue. Does anyone have a resolution? We are running Kanaka 2.7.

    Thanks,
    Kim McCann
    Rose Tree Media School District