dhcp option 121?

Looking through the DNSDHCP console. I find dhcp option 33 for a
static route to a single object. But I need option 121 so I can
specify the netmask and I can't find it. Is this not available in
Novell's implementation?

If not, hiow would you handle this? I have two LANs. The perimeter
firewall for each LAN is the default gateway and they also provide a
site to site VPN. Traffic doesn't have any problems routing. But I
am adding a private line to replace the VPN. The firewall's will
remain the default route. The private line will be connected to each
LAN with routers and the computers on each LAN will no longer use the
default route to find computers on the other LAN. I thought the easy
way would be to just push out the route with DHCP, but I can't seem to
find a way. Any other options?

Ken
  • Hi Ken,

    You can add custom/vendor options by first defining the option number
  • On Fri, 18 Apr 2014 03:06:01 GMT, magic31
    <magic31@no-mx.forums.novell.com> wrote:

    >
    >Hi Ken,
    >
    >You can add custom/vendor options by first defining the option number
  • Opened an SR and got it resolved. For anyone else here is what you
    need to do. The DNSDHCP console is broken so you have to start the
    process there and finish it in iManager.

    I wanted to specify a network of 192.168.3.0/24 wtih a gateway of
    192.168.1.253. The desired line should be:

    option classless-static-routes 24,192,168,3,192,168,1,253;

    1. In the DNSDHCP console, select Custom Options and enter the
    following:
    DHCP option code: 121
    data syntax: List of (1 byte) integers
    description: classless-static-routes

    2. In the DNSDHCP console, select your object, then select Configured
    Options, Modify and add option 121 and enter the mask of 24 only

    3. Open iManager and browse to the object you selected in step 2,
    select modify object, edit the dhcpOption attribute and add
    ",192,168,3,192,168,1,253;" without the quotes after the number 24

    4. Restart the dhcp service. The option should show up in
    /var/log/dhcp-ldap-startup.log and should be handed out to clients.

    Ken
  • ketter;2316153 wrote:
    Opened an SR and got it resolved. For anyone else here is what you
    need to do. The DNSDHCP console is broken so you have to start the
    process there and finish it in iManager.

    I wanted to specify a network of 192.168.3.0/24 wtih a gateway of
    192.168.1.253. The desired line should be:

    option classless-static-routes 24,192,168,3,192,168,1,253;

    1. In the DNSDHCP console, select Custom Options and enter the
    following:
    DHCP option code: 121
    data syntax: List of (1 byte) integers
    description: classless-static-routes

    2. In the DNSDHCP console, select your object, then select Configured
    Options, Modify and add option 121 and enter the mask of 24 only

    3. Open iManager and browse to the object you selected in step 2,
    select modify object, edit the dhcpOption attribute and add
    ",192,168,3,192,168,1,253;" without the quotes after the number 24

    4. Restart the dhcp service. The option should show up in
    /var/log/dhcp-ldap-startup.log and should be handed out to clients.

    Ken


    Hi Ken,

    Great info on the needed extra step for this option. Thanks for feeding that back.
    Any idea if there is a bug open on that defect?

    Also curious, the value ",192,168,3,192,168,1,253;"... is that missing a digit or two, or is that me? :)

    Cheers,
    Willem
  • On Mon, 28 Apr 2014 13:36:01 GMT, magic31
    <magic31@no-mx.forums.novell.com> wrote:

    >
    >ketter;2316153 Wrote:
    >> Opened an SR and got it resolved. For anyone else here is what you
    >> need to do. The DNSDHCP console is broken so you have to start the
    >> process there and finish it in iManager.
    >>
    >> I wanted to specify a network of 192.168.3.0/24 wtih a gateway of
    >> 192.168.1.253. The desired line should be:
    >>
    >> option classless-static-routes 24,192,168,3,192,168,1,253;
    >>
    >> 1. In the DNSDHCP console, select Custom Options and enter the
    >> following:
    >> DHCP option code: 121
    >> data syntax: List of (1 byte) integers
    >> description: classless-static-routes
    >>
    >> 2. In the DNSDHCP console, select your object, then select Configured
    >> Options, Modify and add option 121 and enter the mask of 24 only
    >>
    >> 3. Open iManager and browse to the object you selected in step 2,
    >> select modify object, edit the dhcpOption attribute and add
    >> ",192,168,3,192,168,1,253;" without the quotes after the number 24
    >>
    >> 4. Restart the dhcp service. The option should show up in
    >> /var/log/dhcp-ldap-startup.log and should be handed out to clients.
    >>
    >> Ken

    >
    >Hi Ken,
    >
    >Great info on the needed extra step for this option. Thanks for feeding
    >that back.
    >Any idea if there is a bug open on that defect?


    Hi Willem,
    Yes. Bug # is 874529.

    >Also curious, the value ",192,168,3,192,168,1,253;"... is that missing a
    >digit or two, or is that me? :)


    It is kind of odd. But the example I found on the OpenSuse forum
    dropped any zeros. Not sure why. And not sure how, but it does work.

    I would have thought that I wanted this:
    option classless-static-routes 24,192,168,3,0,192,168,1,253;
    But removing the zero works. I might test it both ways when I get the
    chance to see what happens.

    Ken

  • On 28/04/2014 17:49, KeN Etter wrote:

    > It is kind of odd. But the example I found on the OpenSuse forum
    > dropped any zeros. Not sure why. And not sure how, but it does work.
    >
    > I would have thought that I wanted this:
    > option classless-static-routes 24,192,168,3,0,192,168,1,253;
    > But removing the zero works. I might test it both ways when I get the
    > chance to see what happens.


    According to RFC 3442[1] adding a zero will break it - the 24 indicates
    that the subnet following (192.168.3) has a subnet mask of 255.255.255.0
    so the .0 bit of subnet 192.168.3.0 is not included.

    HTH.

    [1] https://tools.ietf.org/html/rfc3442
    --
    Simon
    Novell Knowledge Partner

    ------------------------------------------------------------------------
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below. Thanks.
    ------------------------------------------------------------------------
  • On Tue, 29 Apr 2014 09:46:48 GMT, Simon Flood
    <smflood@no-mx.forums.novell.com> wrote:

    >On 28/04/2014 17:49, KeN Etter wrote:
    >
    >> It is kind of odd. But the example I found on the OpenSuse forum
    >> dropped any zeros. Not sure why. And not sure how, but it does work.
    >>
    >> I would have thought that I wanted this:
    >> option classless-static-routes 24,192,168,3,0,192,168,1,253;
    >> But removing the zero works. I might test it both ways when I get the
    >> chance to see what happens.

    >
    >According to RFC 3442[1] adding a zero will break it - the 24 indicates
    >that the subnet following (192.168.3) has a subnet mask of 255.255.255.0
    >so the .0 bit of subnet 192.168.3.0 is not included.
    >
    >HTH.
    >
    >[1] https://tools.ietf.org/html/rfc3442


    Thanks...I won't bother testing...I don't need to break anything. :-)