dns failing

OES 11 / SLES 11 SP1 server running DNS. Twice now during the last
couple of weeks, DNS has failed. rcnovell-named status reports
unused. So I start it and it runs again for a while. Is there a log
file somewhere that would tell me what is happening? If not, any
suggestions?

I know the server isn't current...started to update my OES servers
only to run into an NCP/kernel issue. So I'm waiting on that fix
before continuing with the patching.

Ken
  • On Tue, 26 Feb 2013 21:27:10 GMT, KeN Etter
    <ketter@no-mx.forums.novell.com> wrote:

    >OES 11 / SLES 11 SP1 server running DNS. Twice now during the last
    >couple of weeks, DNS has failed. rcnovell-named status reports
    >unused. So I start it and it runs again for a while. Is there a log
    >file somewhere that would tell me what is happening? If not, any
    >suggestions?
    >
    >I know the server isn't current...started to update my OES servers
    >only to run into an NCP/kernel issue. So I'm waiting on that fix
    >before continuing with the patching.
    >
    >Ken


    Sorry for the double post...still having problems with my news reader.
    Waiting on news reader support to get back to me.
  • ketter;2249053 wrote:
    OES 11 / SLES 11 SP1 server running DNS. Twice now during the last
    couple of weeks, DNS has failed. rcnovell-named status reports
    unused. So I start it and it runs again for a while. Is there a log
    file somewhere that would tell me what is happening? If not, any
    suggestions?

    I know the server isn't current...started to update my OES servers
    only to run into an NCP/kernel issue. So I'm waiting on that fix
    before continuing with the patching.

    Ken


    Hey Ken,

    Define "isn't current"? ;-)

    If it's really not current, see: Support | DNS is not responsive or cores which might help until you get things patched up.

    Cheers,
    Willem
  • On Wed, 27 Feb 2013 19:06:02 GMT, magic31
    <magic31@no-mx.forums.novell.com> wrote:

    >
    >ketter;2249053 Wrote:
    >> OES 11 / SLES 11 SP1 server running DNS. Twice now during the last
    >> couple of weeks, DNS has failed. rcnovell-named status reports
    >> unused. So I start it and it runs again for a while. Is there a log
    >> file somewhere that would tell me what is happening? If not, any
    >> suggestions?
    >>
    >> I know the server isn't current...started to update my OES servers
    >> only to run into an NCP/kernel issue. So I'm waiting on that fix
    >> before continuing with the patching.
    >>
    >> Ken

    >
    >Hey Ken,
    >
    >Define "isn't current"? ;-)


    OES 11 on SLES 11 SP1

    >If it's really not current, see: 'Support | DNS is not responsive or
    >cores' (http://www.novell.com/support/kb/doc.php?id=7006015) which might
    >help until you get things patched up.


    Doesn't seem to apply...however I do have lots of these showing up in
    named.run

    general: socket: error: socket: too many open file descriptors

    client: query: warning: client 192.168.1.125#1038: no more recursive
    clients: quota reached

    How do I resolve those?

    Ken
  • ketter;2249330 wrote:
    ......however I do have lots of these showing up in
    named.run

    general: socket: error: socket: too many open file descriptors

    client: query: warning: client 192.168.1.125#1038: no more recursive
    clients: quota reached

    How do I resolve those?

    Ken


    Haven't seen those error before... patching would be the first thing to do imo.

    Curious, what is this server generally doing, and how many users is it doing this for?

    -Willem
  • On Thu, 28 Feb 2013 08:56:01 GMT, magic31
    <magic31@no-mx.forums.novell.com> wrote:

    >
    >ketter;2249330 Wrote:
    >> ......however I do have lots of these showing up in
    >> named.run
    >>
    >> general: socket: error: socket: too many open file descriptors
    >>
    >> client: query: warning: client 192.168.1.125#1038: no more recursive
    >> clients: quota reached
    >>
    >> How do I resolve those?
    >>
    >> Ken

    >
    >Haven't seen those error before... patching would be the first thing to
    >do imo.


    On the list to do...hopefully soon.

    >Curious, what is this server generally doing, and how many users is it
    >doing this for?


    About 60 users. File server, iPrint, NetStorage, DNS, DHCP.
  • Have you looked into memory consumption of novell-named? I have an
    OES11SP1 server, which is running novell-named for just a few users and
    machines and memory consumption is steadily growing (see attached
    screebshot) till a reboot or a restart of novell-named. I would assume
    that this could also kill novell-named, if memory used gets to big.

    --
    W. Prindl


    KeN Etter wrote:

    >OES 11 / SLES 11 SP1 server running DNS. Twice now during the last
    >couple of weeks, DNS has failed. rcnovell-named status reports
    >unused. So I start it and it runs again for a while. Is there a log
    >file somewhere that would tell me what is happening? If not, any
    >suggestions?
    >
    >I know the server isn't current...started to update my OES servers
    >only to run into an NCP/kernel issue. So I'm waiting on that fix
    >before continuing with the patching.
    >
    >Ken



  • Sounds like you might be hitting a hard limit on the number of recursion lookups you are allowing on the server. You can either disable recursion and let the clients look things up, or bump up the hard limit of recursions.