oes 11 server time not correct

I am setting up a new OES 11 SP2 server. Shut it down to add some
hardware. Not sure what the time was saying prior to the restart, but
I just noticed the time is off. date gives me this info:
Tue Feb 17 06:25:32 EST 2015
I checked the master (and my time server) and it reports:
Tue Feb 17 11:25:51 EST 2015
What would be throwing this off by 5 hours and how do I correct it?

Thanks,
Ken
  • Launch Yast, go to Network Services, NTP Configuration.

    Set it up. If you have set it up, be sure you set it to run now and on
    bootup. You may also need to "slam" the time since its far off and NTP
    does not allow adjustments beyond 1000 seconds as it detects that as a
    serious condition requiring intervention. Slamming time can be done with
    ntpdate or sntp (run as 'root'):


    ntpdate -u time.server.goes.here
    sntp -P no -r time.server.goes.here


    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...
  • On Tue, 17 Feb 2015 17:21:48 GMT, ab <ab@no-mx.forums.novell.com>
    wrote:

    >Launch Yast, go to Network Services, NTP Configuration.
    >
    >Set it up. If you have set it up, be sure you set it to run now and on
    >bootup. You may also need to "slam" the time since its far off and NTP
    >does not allow adjustments beyond 1000 seconds as it detects that as a
    >serious condition requiring intervention. Slamming time can be done with
    >ntpdate or sntp (run as 'root'):
    >
    >

    >ntpdate -u time.server.goes.here
    >sntp -P no -r time.server.goes.here
    >


    I do have it setup. And everything in yast is set correctly. I went
    into Yast, date and time, and told it to sync now and it did correct
    itself, but I'm concerned about next reboot.

    Ken
  • ketter;2347372 wrote:
    ...

    I do have it setup. And everything in yast is set correctly. I went
    into Yast, date and time, and told it to sync now and it did correct
    itself, but I'm concerned about next reboot.


    This is a dedicated server hardware for OES? Or is it running virtualized? And if the latter, what viurtualization platform?

    If it's dedicated server hardware, the bios clock might not be syncing up with the system/OS time?

    Cheers,
    Willem
  • On 17/02/2015 18:20, KeN Etter wrote:

    > I do have it setup. And everything in yast is set correctly. I went
    > into Yast, date and time, and told it to sync now and it did correct
    > itself, but I'm concerned about next reboot.


    Is the NTP daemon set to run on server startup? What does "chkconfig
    ntp" report? If "ntp off" run "chkconfig ntp on".

    HTH.
    --
    Simon
    Novell Knowledge Partner

    ------------------------------------------------------------------------
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below. Thanks.
    ------------------------------------------------------------------------
  • On Tue, 17 Feb 2015 22:36:01 GMT, magic31
    <magic31@no-mx.forums.novell.com> wrote:

    >This is a dedicated server hardware for OES? Or is it running
    >virtualized? And if the latter, what viurtualization platform?


    physical server, not a vm

    >If it's dedicated server hardware, the bios clock might not be syncing
    >up with the system/OS time?


    If so, I'm not sure why. I set this server up the same way I've done
    every other OES 11 physical server.

    Ken
  • On Wed, 18 Feb 2015 10:39:54 GMT, Simon Flood
    <smflood@no-mx.forums.novell.com> wrote:

    >Is the NTP daemon set to run on server startup? What does "chkconfig
    >ntp" report? If "ntp off" run "chkconfig ntp on".


    It is set to run at startup. I'll have to troubleshoot some more
    today.

    Ken
  • On Wed, 18 Feb 2015 13:46:27 GMT, KeN Etter
    <ketter@no-mx.forums.novell.com> wrote:

    >On Wed, 18 Feb 2015 10:39:54 GMT, Simon Flood
    ><smflood@no-mx.forums.novell.com> wrote:
    >
    >>Is the NTP daemon set to run on server startup? What does "chkconfig
    >>ntp" report? If "ntp off" run "chkconfig ntp on".

    >
    >It is set to run at startup. I'll have to troubleshoot some more
    >today.
    >
    >Ken


    And now it is working and I don't know why. I like knowing why, but
    not to be with this one...I have too many other tasks waiting to be
    done.

    But thanks all for the help.

    Ken
  • ketter;2347361 wrote:
    I am setting up a new OES 11 SP2 server. Shut it down to add some
    hardware. Not sure what the time was saying prior to the restart, but
    I just noticed the time is off. date gives me this info:
    Tue Feb 17 06:25:32 EST 2015
    I checked the master (and my time server) and it reports:
    Tue Feb 17 11:25:51 EST 2015
    What would be throwing this off by 5 hours and how do I correct it?

    Thanks,
    Ken


    I see that you already had this correct itself but I thought I'd document these -

    We've found it key to double check the time zone, access to NTP servers, make sure port 123 is not open unless you plan on the server being an NTP source, and delete the undisciplined source.
    (Since you are EST/EDT, you'd be GMT-5. So 5 hours always makes me think something off with Time Zone.)

    ntpq
    ntpq> lpeers

    For virtualized(VMs) make sure to delete the local undisciplined clock and actually sometimes on physical or so I've read. If you don't deleted the undisciplined time drifts on and off sync. (Not by five hours though.)
  • On Fri, 27 Mar 2015 14:36:01 GMT, nlandas
    <nlandas@no-mx.forums.novell.com> wrote:

    >
    >ketter;2347361 Wrote:
    >> I am setting up a new OES 11 SP2 server. Shut it down to add some
    >> hardware. Not sure what the time was saying prior to the restart, but
    >> I just noticed the time is off. date gives me this info:
    >> Tue Feb 17 06:25:32 EST 2015
    >> I checked the master (and my time server) and it reports:
    >> Tue Feb 17 11:25:51 EST 2015
    >> What would be throwing this off by 5 hours and how do I correct it?
    >>
    >> Thanks,
    >> Ken

    >
    >I see that you already had this correct itself but I thought I'd
    >document these -
    >
    >We've found it key to double check the time zone, access to NTP servers,
    >make sure port 123 is not open unless you plan on the server being an
    >NTP source, and delete the undisciplined source.
    >(Since you are EST/EDT, you'd be GMT-5. So 5 hours always makes me think
    >something off with Time Zone.)
    >
    >ntpq
    >ntpq> lpeers
    >
    >For virtualized(VMs) make sure to delete the local undisciplined clock
    >and actually sometimes on physical or so I've read. If you don't deleted
    >the undisciplined time drifts on and off sync. (Not by five hours
    >though.)


    Thanks for that information. I'll review things on my end.
    Ken