How to set JRE_HOME / JAVA_HOME

Hi,

I have a question about the JAVA Installation for Vibe 4.0 on a SLES 11SP4.

I followed the steps for "Oracle JDK on Linux" from here:
https://www.novell.com/documentation/vibe4/vibe4_inst/data/biz4gbl.html

If I start Vibe via
/etc/init.d/teaming start


I can read:
Using JRE_HOME:        /usr/jre


and the catalina.out says:
/usr/jre/bin/java: No such file or directory

As from the documentation neither JRE_HOME or JAVA_HOME is set,
so I tried to setting them. But this did not help also.

I found that they are set in /opt/novell/teaming/apache-tomcat/bin/catalina.sh:
108: JAVA_HOME="/usr"
109: JRE_HOME="/usr/jre"


as a workaround I created a symlink like:
/usr/jre -> /usr/java/latest
where this symlinks to:
/usr/java/latest -> /usr/java/jdk1.8.0_65

So is there something missing in the documentation
or how should I set JRE_HOME or JAVA_HOME?

cu SveN
Parents
  • Maybe in the installer on linux is not set correctly. btw. it is a variable in the setup.

    regards


    Schleissheimer;2410408 wrote:
    Hi,

    I have a question about the JAVA Installation for Vibe 4.0 on a SLES 11SP4.

    I followed the steps for "Oracle JDK on Linux" from here:
    https://www.novell.com/documentation/vibe4/vibe4_inst/data/biz4gbl.html

    If I start Vibe via
    /etc/init.d/teaming start


    I can read:
    Using JRE_HOME:        /usr/jre


    and the catalina.out says:
    /usr/jre/bin/java: No such file or directory

    As from the documentation neither JRE_HOME or JAVA_HOME is set,
    so I tried to setting them. But this did not help also.

    I found that they are set in /opt/novell/teaming/apache-tomcat/bin/catalina.sh:
    108: JAVA_HOME="/usr"
    109: JRE_HOME="/usr/jre"


    as a workaround I created a symlink like:
    /usr/jre -> /usr/java/latest
    where this symlinks to:
    /usr/java/latest -> /usr/java/jdk1.8.0_65

    So is there something missing in the documentation
    or how should I set JRE_HOME or JAVA_HOME?

    cu SveN
Reply
  • Maybe in the installer on linux is not set correctly. btw. it is a variable in the setup.

    regards


    Schleissheimer;2410408 wrote:
    Hi,

    I have a question about the JAVA Installation for Vibe 4.0 on a SLES 11SP4.

    I followed the steps for "Oracle JDK on Linux" from here:
    https://www.novell.com/documentation/vibe4/vibe4_inst/data/biz4gbl.html

    If I start Vibe via
    /etc/init.d/teaming start


    I can read:
    Using JRE_HOME:        /usr/jre


    and the catalina.out says:
    /usr/jre/bin/java: No such file or directory

    As from the documentation neither JRE_HOME or JAVA_HOME is set,
    so I tried to setting them. But this did not help also.

    I found that they are set in /opt/novell/teaming/apache-tomcat/bin/catalina.sh:
    108: JAVA_HOME="/usr"
    109: JRE_HOME="/usr/jre"


    as a workaround I created a symlink like:
    /usr/jre -> /usr/java/latest
    where this symlinks to:
    /usr/java/latest -> /usr/java/jdk1.8.0_65

    So is there something missing in the documentation
    or how should I set JRE_HOME or JAVA_HOME?

    cu SveN
Children
No Data