Automatically Changing to a non-US Keyboard Layout for Imaging

0 Likes
over 14 years ago

I've got an update to this Cool Solution that I wrote in 2006 that explained how to change the keyboard mapping in the ZENworks Imaging Environment. Novell has now released ZENworks Configuration Management and ZENworks 7 Sp1 IR1 (and several previous Hotpatches). The Loadkeys command that we used in the previous article has now changed.



Here's a new section where I explain the new method of doing it.



For ZENworks 10 Configuration Management



PROBLEM: The Keyboard Layout in the ZENworks Imaging Environment defaults to a US layout. However, not everyone in the world uses a US Keyboard layout and this can cause problems when trying to type the correct command line at the bash prompt.



SOLUTION: Use the loadkeys utility to change the keyboard mapping file being used.



The loadkeys utility is hidden away in the /lbin folder. It's very straightforward to use:



loadkeys uk



will change the keyboard layout to UK format.



If this is not the layout that you want to use - have a look in /kbd/keymaps/ as this is where the keymap files are stored.



Now running the loadkeys command every time you boot to the bash prompt might be fun for you, but I'm lazy so I wanted to automate the change.



To do this you will need to update the /tftp/boot/settings.txt


Add the appropriate command to the bottom of this file:



loadkeys <keyboard map file name>



where the keyboard map file name is one of the following:



br-abnt2.map

cz-us-qwertz.map

de-lat1-nd.map

de-latin1.map

dk.map

es.map

fi.map

fr-latin1.map

gr.map

hu.map

it.map

jp106.map

nl.map

no-latin1.map

Pl02.map

pt-latin1.map

ru1.map

sk-qwerty.map

sv-latin1.map

uk.map

us.map



When you next PXE-boot your machine, you should have the appropriate keyboard layout -- and you don't need to edit or update your initrd files to get it to work.






For ZENworks 6.5 SP2 or ZENworks 7 Imaging Environment



PROBLEM: The Keyboard Layout in the ZENworks Imaging Environment defaults to a US layout. However, not everyone in the world uses a US Keyboard layout and this can cause problems when trying to type the correct command line at the bash prompt.



SOLUTION: Use the loadkeys utility to change the keyboard mapping file being used.



EXAMPLE: I've wondered how to swap the keyboard layout for some time as we have several customers around the world.



The loadkeys utility is hidden away in the /lbin folder.
It's very straightforward to use:

/lbin/loadkeys uk

will change the keyboard layout to UK format.



If this is not the layout that you want to use - have a look in /kbd/keymaps/ as this is where the keymap files are stored.



Now running the loadkeys command every time you boot to the bash prompt might be fun for you, but I'm lazy so I wanted to automate the change.



To do this you will need to update the /tftp/boot/settings.txt


Add the appropriate command to the bottom of this file:

/lbin/loadkeys <keyboard map file name>



where the keyboard map file name is one of the following:



br-abnt2.map

cz-us-qwertz.map

de-lat1-nd.map

de-latin1.map

dk.map

es.map

fi.map

fr-latin1.map

gr.map

hu.map

it.map

jp106.map

nl.map

no-latin1.map

Pl02.map

pt-latin1.map

ru1.map

sk-qwerty.map

sv-latin1.map

uk.map

us.map



When you next PXE-boot your machine, you should have the appropriate keyboard layout -- and you don't need to edit or update your initrd files to get it to work.




If you have any questions you may contact Jamie at jamie_glendinning_TAKETHISOUT@TAKETHISOUTTOOengl.co.uk


Labels:

How To-Best Practice
Comment List
Anonymous
Related Discussions
Recommended