upgrade to 11.2 stuck at awaiting reboot

I have a single primary ZCM server running on Windows. It was at 11.1
and after running the 11.2 update, it requested a reboot. After
rebooting it appears that most of the update took, but looking at the
status of the server in the ZCM console it says it's "awaiting reboot"
I've rebooted the server numerous times, but the status never changes.
I've re-ran the update and it finishes successfully, requests a reboot,
I let it reboot, and then the status still says "awaiting reboot" One
other thing I'm wondering about is the manual agent download page at
/myserver/zenworks-setup/ still only has 11.1 agents available for
download. Are these supposed to be at 11.2 after the update? Any
hints out there?

-Mike

Tags:

Parents
  • Mike,

    time to check the system-update log

    --

    Shaun Pond


  • In the log folder of the 11.2 upgrade GUID the system-update.log file
    shows no errors.

    If I try to verify the database using the zdc_verifyDB.bat file, I get
    an error that says:
    The baseline file does not contain data for verifier 'zendatabase'


    If I go to the work\system-update folder, the updates-inprocess file
    shows the GUID of the 11.2 upgrade. In the same folder, there is a
    folder with the GUID of the upgrade. If I go in there I see a file
    called: lpm-server.properties with the following contents:

    Debug=false
    TTL=24
    subscription-proxyaddress=
    subscription-proxyport=
    subscription-proxyuser=
    subscription-proxypassword=
    subscription-useNTLM=false
    useNCCViaProxy=false
    # If you want to use same proxy for both NCC and Subscriptions use the
    properties mentioned in the lpm-server.properties file.
    # Else If you want to use different proxy settings for NCC use following
    properties by adding into properties file.
    #ncc-proxyaddress=
    #ncc-proxyport=
    #ncc-proxyuser=
    #ncc-proxypassword=

    I've rebooted numerous times, and tried reinstalling numerous times.

    -Mike









    On 4/11/2012 2:51 AM, Shaun Pond wrote:
    > Mike,
    >
    > time to check the system-update log
    >


  • Do you see any warnings, error etc. in the *Novell\ZENworks\logs\ZENworks_Upgrade_"date".log.xml file?

    You don't have the "Update for ZENworks (11 SP2)" under the System Update page?

    Which zdc (data) file do you use when running the verify? It could return this error if it's made for the wrong, old, version.

    mrmasse;2188747 wrote:
    In the log folder of the 11.2 upgrade GUID the system-update.log file
    shows no errors.

    If I try to verify the database using the zdc_verifyDB.bat file, I get
    an error that says:
    The baseline file does not contain data for verifier 'zendatabase'


    If I go to the work\system-update folder, the updates-inprocess file
    shows the GUID of the 11.2 upgrade. In the same folder, there is a
    folder with the GUID of the upgrade. If I go in there I see a file
    called: lpm-server.properties with the following contents:

    Debug=false
    TTL=24
    subscription-proxyaddress=
    subscription-proxyport=
    subscription-proxyuser=
    subscription-proxypassword=
    subscription-useNTLM=false
    useNCCViaProxy=false
    # If you want to use same proxy for both NCC and Subscriptions use the
    properties mentioned in the lpm-server.properties file.
    # Else If you want to use different proxy settings for NCC use following
    properties by adding into properties file.
    #ncc-proxyaddress=
    #ncc-proxyport=
    #ncc-proxyuser=
    #ncc-proxypassword=

    I've rebooted numerous times, and tried reinstalling numerous times.

    -Mike









    On 4/11/2012 2:51 AM, Shaun Pond wrote:
    > Mike,
    >
    > time to check the system-update log
    >
  • On 4/13/2012 3:16 AM, nop1983 wrote:
    >
    > Do you see any warnings, error etc. in the
    > *Novell\ZENworks\logs\ZENworks_Upgrade_"date".log.xml file?


    The only warning given in that log file is: "The update has already
    assigned to this device. Going ahead"
    >
    > You don't have the "Update for ZENworks (11 SP2)" under the System
    > Update page?


    Yes, I do have that. The stage listed is the "Selected Devices Stage"
    and this server is listed under the pending heading. If I click on the
    server it shows that all of the version numbers appear to be at 11.2,
    but in the lower right hand column in the Assigned System Updates box,
    it shows "Update for ZENworks (11 SP2) Awaiting Reboot" Even though
    the stats on the page show that everything is at 11.2, if I try to make
    a deployment package, it creates an 11.1 version. Machines that have
    already been deployed and are at 11.1 are updating to 11.2 on there own
    though, so it's as if it's mostly installed, just not quite 100%.


    >
    > Which zdc (data) file do you use when running the verify? It could
    > return this error if it's made for the wrong, old, version.
    >


    I was able to get it pointed to the proper data file, and it now reports
    that the database is good.

Reply
  • On 4/13/2012 3:16 AM, nop1983 wrote:
    >
    > Do you see any warnings, error etc. in the
    > *Novell\ZENworks\logs\ZENworks_Upgrade_"date".log.xml file?


    The only warning given in that log file is: "The update has already
    assigned to this device. Going ahead"
    >
    > You don't have the "Update for ZENworks (11 SP2)" under the System
    > Update page?


    Yes, I do have that. The stage listed is the "Selected Devices Stage"
    and this server is listed under the pending heading. If I click on the
    server it shows that all of the version numbers appear to be at 11.2,
    but in the lower right hand column in the Assigned System Updates box,
    it shows "Update for ZENworks (11 SP2) Awaiting Reboot" Even though
    the stats on the page show that everything is at 11.2, if I try to make
    a deployment package, it creates an 11.1 version. Machines that have
    already been deployed and are at 11.1 are updating to 11.2 on there own
    though, so it's as if it's mostly installed, just not quite 100%.


    >
    > Which zdc (data) file do you use when running the verify? It could
    > return this error if it's made for the wrong, old, version.
    >


    I was able to get it pointed to the proper data file, and it now reports
    that the database is good.

Children
  • mrmasse,

    Hmm... yes it sounds like it's almost done, but still not full completed. Are you able to open a SR?


    mrmasse;2188950 wrote:
    On 4/13/2012 3:16 AM, nop1983 wrote:
    >
    > Do you see any warnings, error etc. in the
    > *Novell\ZENworks\logs\ZENworks_Upgrade_"date".log.xml file?


    The only warning given in that log file is: "The update has already
    assigned to this device. Going ahead"
    >
    > You don't have the "Update for ZENworks (11 SP2)" under the System
    > Update page?


    Yes, I do have that. The stage listed is the "Selected Devices Stage"
    and this server is listed under the pending heading. If I click on the
    server it shows that all of the version numbers appear to be at 11.2,
    but in the lower right hand column in the Assigned System Updates box,
    it shows "Update for ZENworks (11 SP2) Awaiting Reboot" Even though
    the stats on the page show that everything is at 11.2, if I try to make
    a deployment package, it creates an 11.1 version. Machines that have
    already been deployed and are at 11.1 are updating to 11.2 on there own
    though, so it's as if it's mostly installed, just not quite 100%.


    >
    > Which zdc (data) file do you use when running the verify? It could
    > return this error if it's made for the wrong, old, version.
    >


    I was able to get it pointed to the proper data file, and it now reports
    that the database is good.
  • No SR capability. After messing for days with this I scrapped the
    server and started fresh with a new 11 sp2 install on a new server and
    everything is much happier now.

    -Mike


    On 4/16/2012 1:06 AM, nop1983 wrote:
    >
    > mrmasse,
    >
    > Hmm... yes it sounds like it's almost done, but still not full
    > completed. Are you able to open a SR?
    >
    >
    > mrmasse;2188950 Wrote:
    >> On 4/13/2012 3:16 AM, nop1983 wrote:
    >>>
    >>> Do you see any warnings, error etc. in the
    >>> *Novell\ZENworks\logs\ZENworks_Upgrade_"date".log.xml file?

    >>
    >> The only warning given in that log file is: "The update has already
    >> assigned to this device. Going ahead"
    >>>
    >>> You don't have the "Update for ZENworks (11 SP2)" under the System
    >>> Update page?

    >>
    >> Yes, I do have that. The stage listed is the "Selected Devices Stage"
    >> and this server is listed under the pending heading. If I click on
    >> the
    >> server it shows that all of the version numbers appear to be at 11.2,
    >> but in the lower right hand column in the Assigned System Updates box,
    >> it shows "Update for ZENworks (11 SP2) Awaiting Reboot" Even
    >> though
    >> the stats on the page show that everything is at 11.2, if I try to
    >> make
    >> a deployment package, it creates an 11.1 version. Machines that
    >> have
    >> already been deployed and are at 11.1 are updating to 11.2 on there
    >> own
    >> though, so it's as if it's mostly installed, just not quite 100%.
    >>
    >>
    >>>
    >>> Which zdc (data) file do you use when running the verify? It could
    >>> return this error if it's made for the wrong, old, version.
    >>>

    >>
    >> I was able to get it pointed to the proper data file, and it now
    >> reports
    >> that the database is good.

    >
    >


  • Okay... sorry to hear that, but good to know you got through it all ;)