Agents cannot determine login

11.2 agents on XP, W7 and Mac are logging into ZCC perfectly fine, and
the agents correctly display who the currently logged in user is.
Inventory seems to not be able to determine logged in user though on any
of the agents. What could cause this?
Parents Reply Children
  • On 4/30/2012 6:55 AM, Shaun Pond wrote:
    > Mike,
    > are you sure someone's logged in at the time you take the inventory?

    Yes, and I've determined it's definitely something on the agent side.
    At the top right it says: Logged in As: <the user>
    I can go to the inventory section and tell it to do a "Scan Now"
    When it completes and I view the inventory details on the client side
    the login field will be empty. So the agent knows who is logged in
    which explains how the ZCC is able to calculate the primary user, but
    for whatever reason the inventory process is not able to see who is
    logged in. Since Asset Inventory LDAP import only uses the
    inventory->login field for users, I can't get it to import user
    demographics properly because that field is not being populated.

  • Mike,

    odd - I get the logged-in user just fine when I do it, so it's not
    "broken" per se - I think it's worth looking at the inventory scan
    files %zenworks_home%\work\inventory xml files, and look for


    Shaun Pond

  • The only thing the inventory log shows related to that is:
    <LoginName />

    One thing I was curious about is that at one point the base image that
    all of these machines are based on had the registry entry to disable
    passive mode logins:


    That entry is no longer there, and it hasn't been there for quite a long
    time, but is it possible that some sort of remnant got left in place due
    to having that entry set in the past? I've tried re-adding the key and
    setting the value to 0 just to see if that would help, but it made no
    change. The agent definitely logs into Zenworks currently.

    These machines all login into Edirectory via the latest Novell Client
    and they also login into a Windows domain at the same time.

    I've also tried doing inventory scans with the machine removed from the
    domain and only logging into Edir and the local machine, as well as
    logging into the local machine only (no Edir, no AD) which of course
    gives the Zen agent login prompt. If I give a valid name and password
    then the agent will show that it's logged in, but the inventory scan
    always shows the login as being empty regardless of what it's actually
    logged into (AD, Edir, Local Machine, Zen Agent)

    On 5/1/2012 8:59 AM, Shaun Pond wrote:
    > Mike,
    > odd - I get the logged-in user just fine when I do it, so it's not
    > "broken" per se - I think it's worth looking at the inventory scan
    > files %zenworks_home%\work\inventory xml files, and look for
    > <LoginName>

  • Mike,

    > <LoginName />

    <loginname> should come just before that


    Shaun Pond

  • On 5/2/2012 11:50 AM, Shaun Pond wrote:
    > Mike,
    >> <LoginName />

    > <loginname> should come just before that

    Here's a snippet of the inventory log:
    <AssetTag />
    <LoginName />

    It appears that when there is a value assigned to a variable, then it
    will have the starting and ending tags, but when the value is null, it
    only has a starting tag with a / after it.

    If I look at ZENLGN.LOG it definately knows what user is logged in and
    if I look at ZCredMgr.LOG it definately knows who's logged in as well,
    but the inventory process cannot figure out the logged in user for some

    Thanks for your time.


  • Mike,

    OK, let me ask some colleagues, since I obviously don't know the answer


    Shaun Pond

  • Are you Running the Full ZCM agent and not just the Assetmanagement/Inventory Parts?
    We do, because we are using ZDM7 to apply policeis and distribute applications with.

    Using only ZCM Assetmanagement/Inventory does not compute logged in user in the same way it seems. And absolutely does not compute Primary User.
    You need the FULL agent to do that.

    Just a thought