UEFI PXE Custom menu

Hi there 

With the normal Legacy PXE boot we edited the .cfg file called by pxemenu.txt

We had edited the initrd which allows us to call a custom script from the .cfg file.

This is what the working one looks like.


DEFAULT imaging

LABEL imaging

                kernel efi\x86_64\linux

                append 5 initrd=efi\x86_64\uctinitefi mode=9 WSCOMMAND=lab.sh  rootimage=/x86_64/root install=tftp://$PXESERVER/efi splash=silent vga=0x314 tftptimeout=50 $KERNEL_PARMS

The above .cfg file works and then the workstation pxe boots and this menu option is selected, the lab.sh runs on the workstation. 


We are not using UEFI and PXE booting machines UEFI mode. 

The pxemenu.txt refers to .conf file and not .cfg file. 

The format of the file is below. I am trying to achieve the same as with Legacy boot and get the script automatically downloaded to the workstation with UEFI booting. 

What do I need to do to the below config to get this working.

The z_maint.conf file in /srv/tftp/efi/x86_64 contains the following.

linuxefi efi/x86_64/linux mode=5 splash=silent showopts vga=0x0314

initrdefi /efi/x86_64/initrd