Coult not open sqlite database error

I have a bundle that copies directories and files down to the ${Windir}\Temp dir. I then run a program from those files then I want to delete the directory structure. Under the Launch Action Set I am using the "Create/Delete directory" action and specify the directory as ${Windir}\Temp\Dell_CC. When I run the bundle, it doesn't delete the directory structure and I get a Policy manager error sent to me by the ZCC as follows:

Device Alias: XXXYYY
Device IP Address: 10.11.12.13
Error: [11/28/16 8:08:28 AM] PolicyManager ActionMan.FailureProcessingActionException Failed to process action: (err=10): Could not open sqlite database

1. What sqlite database is it trying to open? Is this on the ZCC or on the WS that I am running the bundle on?

2. Is there a specific ZCM macro for the system temp directory or do I have to specify it as ${Windir}\temp ?

3. What log file should I look at to get more information about why the bundle action failed? I don't see anything on the WS or in the ZCC under that WS object messages.

Thanks,

dan

Tags:

  • I forgot to mention that I am running the Delete Directory action as the Secure System user. I am assuming that if I delete a parent directory that all subdirectories will be deleted as well. There didn't seem to be a specific option to delete a directory structure.

    Dan
  • Anyone have an idea about why I can't delete a directory structure in a bundle using the "Create/Delete directory" action?

    Dan
  • I use this feature very often and it works.

    Could it be that a file in this dir you want to delete is locked by
    something?
    The delete-action should be the last one. The one directly before that
    is I assume the installation itself. Did you ticked "when action is
    complete" in the Advanced-section of the install action?


    Regards

    Ullrich

    dchunt schrieb:
    >
    > Anyone have an idea about why I can't delete a directory structure in a
    > bundle using the "Create/Delete directory" action?
    >
    > Dan
    >
    >


  • Thanks Ullrich. Yes, I checked the "when action is complete" in the Install action and the delete directory action is the last action. If the directory I am trying to delete has subdirs should the action still work?

    What is the sqlite database it is trying to open? Is this on the WS where the action is trying to run or on the ZCM server?

    What log files should I look at to get more info on why this action isn't working?

    I ended up setting up an Executable action as the last action of the bundle were I run cmd.exe and use the following string:
    /c rmdir /S /Q ${WinDir}\Temp\Dell_CC (Where Dell_cc and subdirs of it is the directory structure I want to delete.)

    That works so I don't think anything has some file in the directory open.

    Dan