Sophos Firewall - Agent Client Deployment

Hi All,

Really hope someone can help!!

I'm currently testing Zenworks 11 in our environment as a possible asset management solution but having issues with deploying the Agent from ZAM.

The issue seems to be with the Sophos Firewall (which protects all my clients). All clients are on domain, and i've added all the Zenworks applications Sophos finds to the whitelist however still not working.

During the install of the log the ZAM server contacts the client, copies a pre_agent file to the clients $admin share and then sends an execution command. It seems to be this command where the error occurs - I think the error code was 267.

The installation doesn't error when 'All Traffic' is allowed, and also completes OK if i install the client manually using a package from ZAM. There is nothing reported via Sophos logs either on the server or client relating to anything being blocked - i can't unblock something that doesn't register...!!!!!

Has anyone else experienced this issue? Any work arounds?

My only solution at the moment is to deploy the client via something like SCCM.

  • Have you checked the documentation to make sure you have all of the necessary ports open? That's where I would start:

    Novell Documentation
    Reference D4 is a comprehensive list of the ports used.
  • Hey.

    Thanks for the link however i've checked all ports required are open.

    To confirm - i forced a rule to ensure the following would be OK


    The server is able to successfully connect via SMB and drop the the preagent file onto the ADMIN share, it just doesn't appear to execute it. This works fine if i allow all traffic.

    I've tried using Wireshark to monitor traffic and notice an error occurring with sending information from the client to the server after the execution command, although unable to work out what this relates to.

    Has anyone else had this issue or using Sophos as a firewall?