Windows 10 Upgrade issues

Having issue when performing an inplace upgrade from Windows 7 to Windows 10 if Zenworks has been installed on the system.

The upgrade will perform just fine, but once you reach the point of logging in, you get a black screen after hitting Ctrl-Alt-Del.

After trying this process multiple times on different machines the closest way I have of working around this issue is to uninstall Zenworks. Delete all files and folders. Then delete all registry keys that refer to Zenworks.

We had thought that upgrading to 11.4.1 would solve this issue, but the same exact thing occurs.

Any help would be appreciated.

  • I'm not sure, but I believe this is a known issue regarding "In-Place Upgrades".
    I believe it has to do with the ZESM and Location Drivers.
    If the System is configured to not use any drivers, then I believe it may go through.

    I could be wrong about it being a "Current Known" issue, but I do know at one point that in place Win7 to Win10 did have issues.
  • Is there a TID or anything on this?

    We do not use ZESM, just ZCM and at this point, the only thing we really use Zenworks for is inventory and Remote Management.

    Is there any suggestions on how to work around this issue? Is there a specific reg key, a hidden driver, or .dll file that is causing this, I assume something that is hooking the login screen? We have tried many different ways of removing and clearing Zenworks and nothing has been 100% reliable except to upgrade a machine that never had Zenworks installed.

    Thanks for your help.
  • If you can open an SR, that may be best.
    I can try to follow the SR, but I will be away in training next week.
  • Actually some of the related issues are in the 11.4.1 Upgrade Readme.
  • So after some trial and error I have found a cause for my issues. It is with the Custom Credential provider that Zenworks uses for sign-on. I can only assume that whatever happens during the upgrade that causes this, is tied to the first time login after performing the upgrade. The Logon tries to process the ZenCredentialProvider and it crashes winlogonui.exe

    Remove the ZenCredentialProvider by deleting this registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\Credential Providers\{692D4DB6-7E51-4370-A9AE-AE95848DBF1E}]

    This allows the first time login to commence and once you have logged in once, you can then restore the key and everything works normally thereafter.

    Using the suggested workaround for this issue from the 11.4.1 readme did not work 100% of the time. It only worked on a test VM box, not the 4 other production PCs I tried it on (1 out of 5).

    In testing, it seems that disabling the User Management in the control center does not always result in the CredProvider keys getting removed from the PC. I am not sure if this is the intended result of the workaround, but I have tried it on 4 more machines and only had it work once. In the other cases the regkey is unable to be deleted because it is in use. I have not yet researched what locks the key in these cases, but at least it is something to go on.
  • The 11.4.1 Readme detailed that is is required to Remove the User Spoke prior to the Windows 10 Upgrade....

    It can be added back after the Windows 10 Upgrade is complete.
    Note: This applies to Windows Server OS Upgrades as well to Windows 2012 R2 or later.

    PS - The "Spoke" settings are found on the settings tab of the device object in the ZCC.