Using the ZENworks Cleanup Tool

I have a WS that has a ZCM 11.4.3 agent in an unusable state. If I try to uninstall the agent from Programs and Features, I get a GPF almost immediately. So I thought I would use the ZENworks Cleanup Tool for 11.4.3. I downloaded the tool, extracted and ran it and this is where I ran into problems.

All I have installed on the WS is the plain ZCM agent. I don't have ZESM or ZENworks Full Disk Encryption installed. However, when I check the box to 'Uninstall ZENworks Agent', it automatically checks the box to 'Uninstall Location Awareness and ZESM options' and 'Uninstall ZENworks Full Disk Encryption'. I can't uncheck these boxes at this point. I assume these are the components that need to have the administrative password for uninstallation.

Then it wants ZENworks Uninstall Authentication. I don't want to pay for a service call to get a support key and I never specified an 'Administrative Password' when the agent was installed originally! I never specified a ZENworks Agent uninstall password, ZENworks Agent override password or ZFDE Administrative password. I don't know where in the ZCC you would do that.

How can I use the tool if I don't have either of these? All I want to do is to remove the malfunctioning ZENworks agent, what am I missing?


  • I don't believe this will work, but you try it anyway.........

    Go to ZCC->Configuration and look straight down the very far left hand side.
    You will see a "Password Generator".

    If I recall, this only helps with FDE not the Cleanup Tool, but you can try.

    Other than that, I'm not sure you would be able to use the tool then w/o help from support.
  • Craig, I looked at that and it seems to me this would only work if the ZCM agent was working properly. My ZCM 11.4.3 agent is in a broken state. I don't see how generating a key with a a password here will get communicated to the WS on which I want to uninstall the agent. Anyway I generated a key with a password then tried putting that in for the 'Use Support Key Information' option of the ZENworks cleanup tool but it comes back with the "The password entered did not match acceptable values. Please try again."

    So just to be clear, the ZENworks Clean-up Tool will ONLY work IF you had created an administrative password initially before installing the agent, right? Or if you pay for a support incident for them to give you their secret key and password. If this is the case, it doesn't seem to be very useful.

    Also, assume that I generated a key with a password using the generator. Where do I use this when installing the agent so that the agent knows about this???


  • Hi Everybody,

    I only write if somesthing have this problem with the tool.
    You don't need to set a password what is syncronizing with the working or non-working agent.
    You need to generate a code when you set a password and expiration day.
    When you run the tool on the workstation, you choose the "Use SUpport Key" at "ZENworks Uninstall Authentication", add the generated code for the "Key", and add the password what you set in the generator to the "Password".
    Let's push the Start button, and after a long time it shows a message to reboot the machine.
    (First uninstall the FDE, second the ZESM, and third the Agent. Sometimes you can see that the tool "Not Responding", but it is working.)

    It is worked for me on 2017 u1 version.

  • Gergely, the issue is that I have to open and pay for a support incident in order to get the password and Key. That is the problem and it is not clear in the documentation that the only way to make use of the tool is to get support to generate the password and key. So you download the tool, do the install and then spend a lot of time trying to figure out why you can't get the ZENworks cleanup tool to work.

  • To use the tool w/o needing a Key Provided by Support is to configure an "uninstall password" which can be supplied to the cleanup tool.
Reply Children