machine GUID getting appended to alias part 2

We tried creating an image with the ZEN agent installed. We ran "zac fsg -d" that would clean out unique identifiers for the agent(on the image), allowing us to deploy an image with the agent ready to go (except no GUID assigned). we kept seeing the appended GUID on the hostname, so we deleted the hosts from ZCC, and tried re registering. This did not work so we used "zac unr" then "zac unr -f" to locally unregister the host. We then used "zac reg -g (server address)". At this point the host name was GUID free when viewing the agent properties from the local machine, but did not appear in ZCC. We didn't touch it for 2 weeks, and now only 7 hosts show up in ZCC. There is one GUID that follows the last host to be "accessed" in ZCC. also there is a duplicate hostname for every alias witht he GUID appended that does NOT have the GUID appended (ex. PC01-f18b345f6sht54, and PC01). It seems the serial may be causing this, but I am at a loss now. Help!!!!
  • I think that I ran into the same problems when I first tried deploying ZCM in my environment and started using imaging. I had a great response to a thread but I can't remember which one but did copy and paste the instructions out of it. I had all of my workstations come in under the same GUID and was unable to use patch management or use ZEN to deliver apps until I fixed them. Give this a try...

    On the computer that is the image source:
    Install OS, agent, apps, updates, etc etc etc
    From the command line run the following commands
    1. zac unr (unregisters workstation from zenworks)
    2. zac cc (Clears Zen Cache)
    3. zac fsg –d (Clears Zen GUID info.)

    Delete the following files from C:\Program Files\Novell\Zenworks\Conf
    1. Devicedata (Also delete devicedata.sav if exists)
    2. Deviceguid (Also delete deviceguid.sav if exists)

    Run C:\Program Files\Novell\Zenworks\bin\preboot\ziswin.exe
    1. Click Edit and clear Image-safe Data
    2. Save changes and Close ziswin. Click No if prompted to save again when closing.

    Run your sysprep and let the system shut down and restart into ZEN imaging maintenance mode.
    Once booted and at the new command line type the following commands
    1. zisedit -c (clears ZEN Cache again in case it grabbed anything new)
    2. img (opens the zen imaging window and lets you take or multicast your images)

    Once your systems have restarted and you check the properties of the ZEN agent it should say "unmanaged" at the command prompt type in
    zac reg -g [serverURL] to make the workstation register and regenerate a new GUID when it connects to the server.

    I've gone as far as creating a bat file for connecting and disconnecting workstations from the ZEN server because I found it to be easier than trying to remember the commands every time and having to type in credentials for registering. For example here are what I used

    ZenDisconnect.bat- zac unr
    ZenConnect.bat- zac reg -g -U [ZenAdminUsername] -P [PasswordforNameUsed] [url]http://[zenURLorIPAddress][/url]

    Hope this helps.
  • If you don't want to mess with having to do a zac reg -g [serverURL] command, the following CoolTool has information on getting the ZEN Adaptive Agent in an Image:

    ZCM Imaging - Installing the ZEN Adaptive Agent in the image | Novell User Communities

    This is what I use, and I have no problems with newly imaged machines.
Reply Children
No Data