bundle assign for users in USER SOURCE

Hi everyone,

I've started to use the command line of the ZMAN and I want to assign my bundles to users in User Source that I've configured but I'm not sure what are the good parameters to use. And I don't find any examples about that, and no so much examples of the BA command line at all....

so, I have the start of my command line:

zman ba user bundle1 and after that, how to assign to a user contained in a user source (edir user source)

also, if I could have more examples usages of the zman ba .....

thank you for your help !!

DM

Tags:

  • Dominicm,

    zman ba --help
    gives examples...

    --

    Shaun Pond


  • Dominicm,

    zman ba --help
    gives examples...

    --

    Shaun Pond


  • yes I know Shaun, but no examples about how to browse user sources .....
  • If you want to Browse eDir from the Command Line, you will need to ask
    in the eDir forums. Such LDAP tools do exist.

    On 1/14/2011 11:36 AM, dominicm wrote:
    > yes I know Shaun, but no examples about how to browse user sources .....



    --
    Craig Wilson - MCNE, MCSE, CCNA
    Novell Knowledge Partner

    Novell does not officially monitor these forums.

    Suggestions/Opinions/Statements made by me are solely my own.
    These thoughts may not be shared by either Novell or any rational human.
  • but using user source that is eDir is part of zenworks functionnality, so in the zman ba command line, it should have a parameter for that... it's a zenworks case I guess.... but if it's suppose to be this way I will try a post on edir forums
  • Dominicm,

    you can't browse on a command line, you're supposed to know the path :)
    If you don't know, you can use ZCC

    --

    Shaun Pond


  • dominicm;2064869 wrote:
    yes I know Shaun, but no examples about how to browse user sources .....


    Whilst the other responses are technically correct, you need to know how zenworks refers to users, so that you can assign bundles to them.
    "zman user-list" is what your after. When run by itself, it will return something like the following.

    Displaying 1 - 2 of 2 results:
    -----------------------------------------------------------------
    Name | Primary Type | Sub Type | Folder
    --------------------- -------------- -------------------- -------
    ZENworks User Groups | Folder | User Folder | /Users
    TREE_NAME | Folder | User Source Folder | /Users



    for me, running "zman user-list /Users/TREE_NAME", returns ...
    Displaying 1 - 1 of 1 results:
    ---------------------------------------------------------------
    Name | Primary Type | Sub Type | Folder
    ------------- -------------- ------------- --------------------
    TREE_NAME | Folder | User Folder | /Users/TREE_NAME


    so running "zman user-list /Users/TREE_NAME/TREE_NAME" will finally start listing the 'O=' containers

    So you probably don't need to run it anyfurther, as you probably know how your tree is setup. So i get the following to assign a bundle to the IT crew.

    zman ba user '/Bundles/NetAdmin/Server Connections' /Users/TREE_NAME/TREE_NAME/ORG/ITS

    Successfully assigned "/Bundles/NetAdmin/Server Connections" to "/Users/TREE_NAME/TREE_NAME/ORG/its".


    We do most of our mapping at the ORG/Container level, so i plan to have a bash script that takes the bundle as a parameter and then assigns it to all the USER containers.

    hope this helps someone.

    P
  • [HTML]
    Hi,
    we have problems in assignin users to bundles and to policies
    We have usersource to our tree "SCHULBAUM03"
    For this usersource we have two user containers, "DIENSTE" and "SCHULEN".
    Usersource looks ok, i can browse in ZCC to SCHULBAUM03/SCHULEN/LFB/Benutzer/Lehrer.

    zman ul SCHULBAUM03/SCHULEN gives the subcontainers, e.g. LFB
    however
    zman ul SCHULBAUM03/SCHULEN/LFB gives error 22, could not find object

    The same is true for
    zman ba user LFB-PGM/Betreuung/Testbundle SCHULBAUM03/SCHULEN/LFB/Benutzer/Lehrer

    It seems, that I can only assign user containers that are explicitly defined in ZCC under the user source
    and not to organizational units below the user containers defined in ZCC.
    ( If this holds true and I have no errors in my usage of zman, assignments with zman are rather useless,
    for it is impossible to define a user container for each Organizational unit in the tree.)

    Do I have any errors in syntax for using this zman options ?
    Please give me an example for the correct syntax.

    Thanks
    Ulrich Frei







    [/HTML]
  • #1 - Make sure the Proxy User has sufficient rights.
    #2 - Make sure the LDAP Servers defined in the ZCC hold all the objects
    in those subcontainers.

    On 12/30/2012 4:56 PM, ufrei wrote:
    >
    > Hi,
    > we have problems in assignin users to bundles and to policies
    > We have usersource to our tree "SCHULBAUM03"
    > For this usersource we have two user containers, "DIENSTE" and
    > "SCHULEN".
    > Usersource looks ok, i can browse in ZCC to
    > SCHULBAUM03/SCHULEN/LFB/Benutzer/Lehrer.
    >
    > zman ul SCHULBAUM03/SCHULEN gives the subcontainers, e.g. LFB
    > however
    > zman ul SCHULBAUM03/SCHULEN/LFB gives error 22, could not find object
    >
    > The same is true for
    > zman ba user LFB-PGM/Betreuung/Testbundle
    > SCHULBAUM03/SCHULEN/LFB/Benutzer/Lehrer
    >
    > It seems, that I can only assign user containers that are explicitly
    > defined in ZCC under the user source
    > and not to organizational units below the user containers defined in
    > ZCC.
    > ( If this holds true and I have no errors in my usage of zman,
    > assignments with zman are rather useless,
    > for it is impossible to define a user container for each
    > Organizational unit in the tree.)
    >
    > Do I have any errors in syntax for using this zman options ?
    > Please give me an example for the correct syntax.
    >
    > Thanks
    > Ulrich Frei
    >
    >



    --
    Craig Wilson - MCNE, MCSE, CCNA
    Novell Knowledge Partner

    Novell does not officially monitor these forums.

    Suggestions/Opinions/Statements made by me are solely my own.
    These thoughts may not be shared by either Novell or any rational human.
  • Hi Craig,
    all the requirements you listet are satisfied.
    In ZCC I can browse in the eDirectory tree to all this containers and I can see all users.
    Ulrich Frei

    craig_wilson;2238076 wrote:
    #1 - Make sure the Proxy User has sufficient rights.
    #2 - Make sure the LDAP Servers defined in the ZCC hold all the objects
    in those subcontainers.

    On 12/30/2012 4:56 PM, ufrei wrote:
    >
    > Hi,
    > we have problems in assignin users to bundles and to policies
    > We have usersource to our tree "SCHULBAUM03"
    > For this usersource we have two user containers, "DIENSTE" and
    > "SCHULEN".
    > Usersource looks ok, i can browse in ZCC to
    > SCHULBAUM03/SCHULEN/LFB/Benutzer/Lehrer.
    >
    > zman ul SCHULBAUM03/SCHULEN gives the subcontainers, e.g. LFB
    > however
    > zman ul SCHULBAUM03/SCHULEN/LFB gives error 22, could not find object
    >
    > The same is true for
    > zman ba user LFB-PGM/Betreuung/Testbundle
    > SCHULBAUM03/SCHULEN/LFB/Benutzer/Lehrer
    >
    > It seems, that I can only assign user containers that are explicitly
    > defined in ZCC under the user source
    > and not to organizational units below the user containers defined in
    > ZCC.
    > ( If this holds true and I have no errors in my usage of zman,
    > assignments with zman are rather useless,
    > for it is impossible to define a user container for each
    > Organizational unit in the tree.)
    >
    > Do I have any errors in syntax for using this zman options ?
    > Please give me an example for the correct syntax.
    >
    > Thanks
    > Ulrich Frei
    >
    >



    --
    Craig Wilson - MCNE, MCSE, CCNA
    Novell Knowledge Partner

    Novell does not officially monitor these forums.

    Suggestions/Opinions/Statements made by me are solely my own.
    These thoughts may not be shared by either Novell or any rational human.