MDT 2013 Zenworks imaging issue

Hello, we are trying to set up pxe boot options for our MDT in Zenworks and I'm having troubles figuring out how we get the deployment wizard to popup instead of just the standard winpe environment. I expected to see the MDT Deployment Wizard popup but what I get is a command prompt loading wpeinit then zenworktodo.exe where it prompts for imaging type: WIM or GHOST. I've tried selecting all the options including query for work and it says there is no third Party imaging work assigned.

So far I have gone in and created a preboot bundle using my 64bit Litetouch.wim file that MDT supplies you with your deployment, it's been fully updated and the current version. I've uploaded the 64 bit winpe and imagex files into the 3rd party imaging options under preboot services (Configuration, Device Management).

We can pxe boot and I get the Zenworks preboot deployment Services Menu to come up in which I select WinPE Maintenance Mode. It then boots to the winpe.wim file but it's the one that comes with the ADK and MDT doesn't get offered in any way. Maybe I'm misunderstanding how you access a MDT created image but that is where I'm at.. Very new to this but am stubborn enough to eventually figure it out just hoping someone can give me some insight on all this. I'm still at a loss somewhat on how it's going to find all the files it needs on my machine. I have given EVERYONE read/write access on my deployment share though so there should be the info included in my custom wim somewhere that will point my machines in the right direction.

Thanks for any help with this. Really wanting to figure this out cause we are so close! :D


  • You need to Create a HW Rule so that New Devices will apply the MDT Preboot Bundle you desire.
    Devices already in the Zone can be assigned this Preboot Bundle.

    WinPE from the Deployment Toolkit will then Startup and then run that bundle which points to the MDT Deployment on one of your shares.
  • Okay I'll create a hardware rule for new devices but even existing devices I've tried applying the bundle to those devices it sees their IP address and everything and nothing happens. I've tried putting a desktop and start menu and system tray icon and I don't see anything that shows up, I've tried pxe boot and it doesn't allow me to get into my MDT deployment it just boots into that zenworks Imaging or the winpe environment. I guess I'm still confused at how it's going to make the connection to launch my MDT deployment wim and not just the base winpe wim.
  • Build Bundle
    1. Start Firefox or Internet Explorer as an Administrator
    2. Login to the ZENworks Control Center
    3. Navigate to /Bundles
    4. Click on New -> Bundle
    5. Select Preboot Bundle and click next.
    6. Select MDT Deployment and click next.
    7. Enter a name: MDT Windows 10
    (Optionally) Enter a description. Click next.
    8. Browse to and upload your MDT Production Deployment WIM file.
    9. Review the summary and click next.

    Build Rule
    Configure Default Imaging Rules
    1. Navigate to /Configuration
    2. Expand Device Management and click on Preboot Services
    3. Expand the Device Imaging Work Assignment section
    4. Next to the Hardware Rules box click on Add
    5. Provide a name: Default Windows 10
    Browse to and select the MDT Bundle that you just created
    Add a rule to use to determine when to apply this bundle
    Click OK.
  • I've done everything you listed above already. It still boots to winpe.wim.

    I made 3 rules. One pointing to my vm computer via IP address rule.
    I made one pointing to a physical machine .. again IP address rule.
    And the last one I made a manufacture rule that contains the word Dell thinking it would pick up any machine as we only have Dell computers.
    The VM Loads into the Zenworks preboot menu and I select Winpe Management mode and that's the furthest I get. It stops when it goes to the dos window at loading winpe.cfg. It's a Windows 7 64 bit virtualbox machine.
    The laptop goes all the way through the preboot menu and even loads the winpe.cfg successfully then continues to boot the winpe.wim not my Litetouch wim in my MDT bundle. I select Look for work and it fails to connect. I try to restore from server and i input my workstation computer name and share: \\nbtc-lworkman\DeploymentShare$\boot\LiteTouch_x64.wim... I was trying to connect to my deploymentshare since i can't connect to the server but that doesn't work either.
    I tried a 3rd machine.. a Dell 390 desktop and it does the same as the 5770 laptop. Loads the 3rd party winpe wim and not my MDT.

    I'm not sure what else to try. I'm at a loss anymore. I have my network admin working with me on this and he was able to get it to boot to the preboot menu by opening the firewall but now it acts like it gets that far then doesn't get us any further. I appreciate all your help on this. I feel we get one step closer but still find us struggling to get this off the ground.
  • "The VM Loads into the Zenworks preboot menu and I select Winpe Management mode"

    You want to select "Automatic Imaging" if you want to use Rules or Assignments.
  • When I choose Automatic Imaging (It's actually Zenworks Imaging), it loads into Zenworks imaging and I'm immediately given an error. (see link for image of error).

    From what I can tell it's not finding the share or something. So I do the only thing I can do and that's click OK and try manual setup.

    I'm given the first set of options:

    Start Installation (seems the obvious choice)
    Exit or Reboot

    I choose the obvious where i"m asked:

    Start Installation or update
    Boot Installed System
    Start Rescue System

    I again choose the obvious and start installation. It then asks me for DVD, Network or Hard Disk. I choose Network. I then have to select the network protocol:
    SMB/CIFS (Windows Share)

    I've chose Windows Share and TFTP and neither work. I choose between 2 network devices, Intel Ethernet Controller or Intel Network Controller. No matter what I select the next thing that comes up is
    NO NETWORK DEVICE FOUND. Load a network module first.

    I've gone through all the settings and tried various things but nothing is getting it to work. You are awesome for sticking with me on this and it's greatly appreciated! I can't understand why I'm getting this but I would have to think it's something that still needs done in the ZCC. My rules are basically If a computer Manufacture contains "Dell", OR, if an IP contains "10" and then 1 more.. OR IP is equal to the one I'm trying to test.

    Do I need to put anything in TFTP Replication under Preboot Services? I have tried adding it and not having it as well and neither make a difference but thought I'd ask. Other than that I'm at a loss but I'll be researching "could not find the Zenworks Repository".
  • So I've since tried a few other things and one was to try and deploy a windows 7 image on an older laptop. It actually gets further and loads a bunch of files but then eventually errors out with "No work to do" then restarts. On my VM I get an error. Zenworks Imaging failed with error:100.
    I also get on my physical machine a few errors.
    insmod: error inserting '/modules/powernow=K8.ko': -1 No such device
    loading --> /download/file_0000
    error 68: TFTP: File Not Found
    loading --> download/file_0001

    It then goes to a screen where it looks like you can select to take an image, load an image or look for work and before I do anything it reboots.
  • So I was able to finally catch the error on the physical machine and it says the same error.. Error 100: Work to do is not of type Zenworks Imaging. It reboots automatically.

    I'm assuming this means that the MDT Deployment isn't a Zenworks image or the bundle I assigned isn't a zenworks file and so it fails. That is why i assumed I would be using WinPE Maintenance mode but that again just boots to the 3rd party winpe.wim file.

    man I'm going bald here! lol
  • After spending almost every waking hour on this over the weekend I am still at a loss for what is going wrong.

    I am consistently getting an the same error everytime now and I've gone as far as deleting my bundle and re-uploading base wims and rules. I also learned how to push my group policies and install apps too which all work perfectly. I also tried vmware and now my vm is booting just like my physical machines. Yet I still cannot deploy my MDT bundle properly.
    I see in another thread where it was suggested that you overwrite the winpe.wim with your LiteTouchPE wim but I don't have access to the server only my network admin does. I plan to have him try this first thing in the morning though. I honestly hate this idea in that it seems dumb to upload all this stuff and then I have to manually alter it to get it to work properly. At this point whatever.. if it works then hallelujah! lol.. I've spent so much time on this and the first time I uploaded my LiteTouch wim to my WDS and booted a VM up it launched my MDT deployment first try. This has been way more difficult than it should be imo.

    The error I'm stuck at right now when I select Zenworks Imaging is: Error 100: Task is not of Zenworks Imaging.
    It then reboots. If I choose WINPE Maintenance Mode it successfully loads the winpe.wim and I get stuck at Zenworktodo.exe where I try to check for work and it says "No third party work available". I've tried with 32 bit and 64 bit vm's bios and uefi... No Go. I did try and restore image and I can browse to my windows share on my own machine and push my LiteTouchPE_x64.wim but that does no good for obvious reasons.
    I wish I could just mount an ISO and push that down using multicast like I used to do with Ghost. That would make my life a ton easier. I make an ISO and a create a bootable flash drive for my deployments as well to fix one machine at a time or install new devices as needed. I just need this PXE boot to work if I'm to change methods this summer. I'm so stubborn I can't let this issue go though I have to conquer it :D I've even tried Manual mode and it doesn't work either. It can't find the server or again No third party images available.

    WHen I get this working I'm going to be doing some YouTube tutorials for every step cause it seems there is something missing in every single article I've read or video I've watched. Or maybe our server is just borked... which I've thought from time to time honestly.
  • We copied the files from the srv\tftp\mdt folder to the srv\tftp\boot folder and that did the trick! It now boots to our MDT wizard!!! Thank God!!! Still though.. this is ridiculous for us to have to do this manually when Zen gives us the option to upload the files in 2 seperate places. Why even bother with third party images if you have a wim already for MDT Deployment. Seems redundant and it doesn't even work in the first place for us.
    I'm going to be pushing for a 2017 upgrade this summer. Something is definitely broke with our Zen server. And even though it's working it's slow as all get out. It's been stuck on installing Office 2016 for about an hour now.