CVE-2024-1597 - PostgreSQL JDBC vulnerability

0 Likes

Summary
Does CVE-2024-1597 - PostgreSQL JDBC vulnerability affects AAF?

Products
Advanced Authentication



Environment
Advanced Authentication Framework 6.3.x and 6.4.x

Situation

Advanced Authentication includes two components (SymmetricDS and Risk Service) which bundle PostgreSQL JDBC (postgresql*.jar).

Advanced Authentication's use of PostgreSQL JDBC in both components do not use the PostgreSQL preferQueryMode=simple setting, therefore Advanced Authentication is not impacted by the PostgreSQL JDBC vulnerability.

Labels:

Support Tip
Comment List
Related
Recommended