Need Help with configuring WS federation and ADFS


I am running the latest version 3.1.4-27. We are trying to configure WS
federation to ADFS 2.0 running in one of the service providers of our
company to access the hosted application. Active directory is our
identity store and I have followed the steps mentioned in the
Documentation except that I used CN attribute as the claim type instead
of email to create the service provider configuration. This is what is
happening - When I try to access the application URL, I am allowed to
select Novell Access manager(NAM) from a list of identity providers they
have configured in ADFS. After selecting, I am prompted with a form
based authentication configured in NAM. After successful authentication,
I am not being forwarded to the application URL instead I sit at the NAM
page that says " Your Session has been authenticated for 60 minutes"

Can anyone walk me through the configuration and help me figure out
what I may be missing?

-NK


--
nareshbk
------------------------------------------------------------------------
nareshbk's Profile: http://forums.novell.com/member.php?userid=43220
View this thread: http://forums.novell.com/showthread.php?t=449720

Parents
  • nareshbk wrote:

    >
    > I am running the latest version 3.1.4-27. We are trying to configure
    > WS federation to ADFS 2.0 running in one of the service providers of
    > our company to access the hosted application. Active directory is our
    > identity store and I have followed the steps mentioned in the
    > Documentation except that I used CN attribute as the claim type
    > instead of email to create the service provider configuration. This
    > is what is happening - When I try to access the application URL, I am
    > allowed to select Novell Access manager(NAM) from a list of identity
    > providers they have configured in ADFS. After selecting, I am
    > prompted with a form based authentication configured in NAM. After
    > successful authentication, I am not being forwarded to the
    > application URL instead I sit at the NAM page that says " Your
    > Session has been authenticated for 60 minutes"
    >
    > Can anyone walk me through the configuration and help me figure out
    > what I may be missing?
    >
    > -NK


    are you using SAML or WS Federation between the two? If you using SAML
    the post to the service provider should contain a relaystate (of the
    top of my head) when using the browser/post binding. Not exactly sure
    how this should work when using WS-Federation tho.

    --
    Cheers,
    Edward

  • I am using WS-Federation. I am blindly following the documentation
    though.


    --
    nareshbk
    ------------------------------------------------------------------------
    nareshbk's Profile: http://forums.novell.com/member.php?userid=43220
    View this thread: http://forums.novell.com/showthread.php?t=449720

Reply Children
No Data