Idea ID: 2825883

Token Does Not Get Exchanged with Authorization Code When Using a Multi-Node Identity Server Cluster

Status : New Idea
over 1 year ago

According to the the documentation of NAM 45 "Troubleshooting OAUTH and OpenID Connect -> The Access Token Does Not Get Exchanged with Authorization Code When Using a Multi-Node Identity Server Cluster", when clients uses "Expect : 100-continue", in a IDP multi-node setup it will give a "HTTP 400 Bad Request error message".

The resolution provided states that the client should disable "Expect : 100-continue", in order for it to work.
This is working in previous version of NAM, but breaks with 4.5.

Instead of requiring clients to adjust their code, which is not always possible, it would be more user friendly if the issue can be resolved on the NAM side.

Labels:

Configuration
Parents Comment Children
No Data