Install ArcSight Console 7 Ubuntu

Hello team,

I tried to install the ArcSight console (Version 7) in Ubuntu but I have a problem with TZdata.

When I install the .bin, I obtain this warning: "TZData update was not successful. Refer to the install instructions for manual updates to your TZData"

clipboard_image_0.png

I don´t found any information related to this error on the install instructions.

Any ideas?

Thanks team

Regards

  • The tzdata needs to be configured for the client to work, an apt-get install tzdata should resolve it.

  • Hello  

    First, thansk for your reply!

    I thought so at the beginning, but when I tried to install the tzdata:

    apt-get install tzdata
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    tzdata is already the newest version (2019b-0ubuntu0.19.04).
    tzdata set to manually installed.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    I do not understand why because a few months ago I could install the console without problems in Ubuntu

    Regards

  • Np!

    Hmm that is weird, what does "cat /etc/localtime" say?

    If its empty or does not exist, can you run this as sudo/root:

    ln -fs /usr/share/zoneinfo/Continent/Country /etc/localtime

    For example:

    ln -fs /usr/share/zoneinfo/America/New_York /etc/localtime

     

  • mm, very weird the output:

    clipboard_image_0.png

    Sorry marius and many thanks for your help!

  • Sorry about that, don't know why i asked for a cat, it's symlinked to a binary, which is why you get that output. What i would have liked to know is where it is symlinked to:

    "ls -ltr /etc/ | grep localtime".

    Though it seems that this has been setup correctly.

    In many cases before, the error message during installation was actually false, and after clicking OK the installation still finalized properly.

    If you click okay, is there anything stopping you from running the console application itself?

  • Hello Marius,

    Yes, the installation ends but not request the final steps (protocol, authentication,manager)...

    Here the output of your command.

    clipboard_image_0.png

    When I try to start the console:

    --

    /arcsight/Console/current/bin$ ./arcsight console

    Assuming ARCSIGHT_HOME: /home/nacho/arcsight/Console/current
    Assuming JAVA_HOME: /home/nacho/arcsight/Console/current/jre

    ArcSight Console starting...

    /home/nacho/arcsight/Console/current/bin/scripts/execjava.sh: 7: /home/nacho/arcsight/Console/current/bin/scripts/functions.sh: Syntax error: "(" unexpected

    --

     

    Regatds,