Upgrade Failed from ESM 7.0 (Patch1) to ESM 7.2

Hey, I need a way out of this issue which I faced earlier where upgrading from ESM7.0 P1 to ESM 7.2 failed with below failure logs:

--------------------------------------------------------------------------
Upgrade Failure
--------------------------------------------------------------------------

Previous installation could not be upgraded successfully.

Reason for failure:
Stopping all components...
Stopping logger daemon...
Logger stopped successfully.
Starting PostgreSQL...ok
Starting MySQL...ok
Stopping APS...APS was not running.
Starting APS...ok
Stopping Apache...Apache was not running.
Starting Apache...ok
Will wait up to PT00:02:00.000 for mysqld to start.

Waited PT00:00:00.881

OK: mysqld service is available
Checking status of manager,logger_web,logger_servers,mysqld before attempting
to stop them.
Will wait up to PT00:15:00.000 for manager to stop.

Waited PT00:00:05.461

OK: manager service is unavailable
Will wait up to PT00:01:00.000 for logger_servers to stop.

Waited PT00:00:00.066

OK: logger_servers service is unavailable
Will wait up to PT00:01:00.000 for logger_web,mysqld to stop.

Waited PT00:01:00.238

OK: logger_web service is unavailable
FAIL: timed out awaiting stop of mysqld service mysqld: available [
mysqld-jdbc: available
]
Problem stopping 'mysqld': logger_web,mysqld did not stop!
Please check service status and stop them.
call to mysql stop returned: 1
ERROR: Unable to stop mysql after applying TZ update.


Any errors:
AH00558: httpd: Could not reliably determine the server's fully qualified
domain name, using a.b.c.server. Set the 'ServerName'
directive globally to suppress this message


Exit Status:
1

Press [Enter] to cancel this installation.

================================================================================

To troubleshoot these two tests were performed, initially by running apachectl configtest returned the same error over to fix the "Fully Qualified Domain Name Director" which was fixed by updating httpd.conf file with ServerName 127.0.0.1 for the server to resolve httpd requests.

Secondly used a command to update mysqld TZ update manually which also returned the same error:
Command: /opt/arcsight/manager/bin/arcsight tzupdater /opt/arcsight /opt/arcsight/manager/lib/jre-tools/tzupdater

Output

============================================================================

Assuming ARCSIGHT_HOME: /opt/x.x.x.x/x.y.z/arcsight/manager
Assuming JAVA_HOME: /opt/arcsight/java/esm/current/jre

sanity checks...
detected CORRe-based ESM...
Verifying installation of OS timezone data rpm...
WARNING: A timezone version 2019b or later RPM is not installed on your operating system.
Updating local time...
Timezone is set correctly
Postgresql timezone data already updated
Starting Mysql TZ update...
call to mysql stop returned: 1
ERROR: Unable to stop mysql after applying TZ update.
[arcsight@a.b.c.server|development|~]$

=============================================================================

Any insights on why this issue occured and if someone else faced this too what could be the possible resolution for this?

TIA

  • I don't have an answer for you, I have seen this before but its normally because there has been a pre-requisite missed or something conflicting with the upgrade. I would raise a support ticket, you will probably have to recover the system and then make sure you have completed all the steps and possibly some additional things that support can guide you through.

    It's hard to say exactly what went wrong without digging through the logs and checking everything thoroughly.