Smartconnector 8.2 Version and Net Framework Version required.

I wander what is the suitable Net framework version for smart connector 8.2 version.