Documentation for Test Alert SmartConnector

Is there somewhere a proper documentation for the Test Connector?

I only found one from 2010 [1] which is not working for me. I installed the connector but it is shown as down continously in ESM. The service on the SmartConnector's server is running actively. The logs of it look good and do not display any errors or warnings.
Do I have to start it somehow else?

[1] community.microfocus.com/.../Using-the-ArcSight-Test-Alert-SmartConnector.pdf

Parents
  • Verified Answer

    So we had a talk with the support and found out where it got stuck. We had to adjust the agent.properties in the following way:

    • agents[0].autoload=true
    • agents[0].loadall=true
    • agents[0].startpaused=false
    • agents[0].uienabled=false

    I do not know which property exactly was the fix of these four but now the connector is working as it was supposed to.

Reply
  • Verified Answer

    So we had a talk with the support and found out where it got stuck. We had to adjust the agent.properties in the following way:

    • agents[0].autoload=true
    • agents[0].loadall=true
    • agents[0].startpaused=false
    • agents[0].uienabled=false

    I do not know which property exactly was the fix of these four but now the connector is working as it was supposed to.

Children
  • The first two deal with the loading of the event files.  If you're using the UI, you'd have to pick which event files you wanted to load.  These to parameters basically say load all of the event files.  The third sets up the connector to start replaying events when the connector start.   I've typically run the connector with the GUI so I wasn't aware of the uienabled option.  But it sounds like it just disables the interface. So it sounds like you're able to start the connector and send events without the GUI starting up.  

    Thanks for posting that. I'm sure others will  find this useful.