This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

TLS for Connectors

Can SmartConncetors be configured to run in TLS v1.2 with aes256 encryption?

Parents
  • Hello,

    please check agent.default.properties:
    <connector_home>/current/config/agent/agent.defaults.properties

    Find following setting (these are available from SmartConnector):

    # The protocols will be used during SSL handshake negotiations in the order in which they are mentioned
    ssl.protocols=TLSv1.2,TLSv1.1,TLSv1

    Delete the protocols (do not do it in agent.default.properties) that you do not use (ESM Destination has to have enabled the cypher that you will use on Connector). Please check this KB on how to do it on ESM KM02267699.

    Add this modified line to agent.properties:
    <connector_home>/current/user/agent/agent.properties

    For example to use only TLS 1.2:
    ssl.protocols=TLSv1.2

    Restart SmartConnecotor to apply settings.

    Regards,
    Marijo

Reply
  • Hello,

    please check agent.default.properties:
    <connector_home>/current/config/agent/agent.defaults.properties

    Find following setting (these are available from SmartConnector):

    # The protocols will be used during SSL handshake negotiations in the order in which they are mentioned
    ssl.protocols=TLSv1.2,TLSv1.1,TLSv1

    Delete the protocols (do not do it in agent.default.properties) that you do not use (ESM Destination has to have enabled the cypher that you will use on Connector). Please check this KB on how to do it on ESM KM02267699.

    Add this modified line to agent.properties:
    <connector_home>/current/user/agent/agent.properties

    For example to use only TLS 1.2:
    ssl.protocols=TLSv1.2

    Restart SmartConnecotor to apply settings.

    Regards,
    Marijo

Children
No Data