Knowledge Doc: [Standard Connectors] Fix remote connector shows status down in ArcMC

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Summary
Somehow SmartConnector stopped running so it cause the status Down in ArcMC. Thus, need to bring the connector up.

Products
ArcSight Standard Connectors

Environment
Connector 8.3
OS: Windows

Situation
SmartConnector is showing Down in ArcMC

Cause
Somehow SmartConnector stopped running so it cause the status Down in ArcMC. Thus, need to bring the connector up.

Resolution
1. Stop SmartConnector service in Windows Services
2. Open Task Manager and End all process which related to the problematic connector.
3. Delete all agent.lock* files under D:\Program Files\ArcSightSmartConnectors\current
un\ folder (Please keep monitor this folder abit to see if the .lock files are not generated more, otherwise, there are some related process still remaining running, then we need to carry on step 2 gain)
4. Open agent.out.wrapper.conf under D:\Program Files\ArcSightSmartConnectors\current\user\agent and modify this parameter to allocate more heap size to connector: wrapper.java.maxmemory=4096
5. Start SmartConnector service

Knowledge Base Article Link


URL Name
KM000009433

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