This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Ruby Support?

Based on the current documentation, it appears that only Ruby version 1.9.3 is supported. Is that a minimum version or does Fortify not support scanning Ruby 2.7.6, 3.0.4, or 3.1.2?

I am receiving translation errors parsing a Ruby 2.7.6 file. For example, 

[2022-06-06 22:28:25.012 ERROR 1001]
Unexpected exception while parsing file generator.rb
com.fortify.frontend.ruby.parser.RubyParser$ParseException: (SyntaxError) generator.rb:8: syntax error, unexpected tLABEL

Thanks,