web browser problem

Hi everyone,


why do always get this problems whenever i use web macro, stepmode or manual scan.


Unable to connect to remote host : A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond [ip]



Parents Reply Children
  • Hi


    Yes, i can access the URLs direct from any browsers. But every time i use webinspect to connect either using stepmode or manual scan it always comes up with that problem. What should i do?



  • This is a network issue, not a WebInspect issue.  The proxy settings would be the first item to review.


    To begin with, WebInspect has two proxy configuration areas.


    1. How WebInspect reaches the Internet and HP:  Edit menu > Application Settings > Proxy panel
    2. How WebInspect reaches the intended scan target:  Edit menu > Default Scan Settings > Proxy panel


    For each of these, the default factory setting is to simply take the proxy settings from Internet Explorer.  Under most conditions this works adequately and requires no user intervention, as MSIE is generally properly configured for its network and for Internet access.  You will find that several of the included tools also use this same assumption and base configuration, such as the Web Macro Recorder, SQL Injector, Web Brute, Web form Editor, et al.


    Difficulties arise when the network proxy requires authentication by the user before the HTTP Request is permitted through.  MSIE automatically "borrows" the current Windows user's credentials and passes these as NTLM if the proxy requires that.  Other non-Microsoft applications, including WebInspect, Firefox, et al, do not have this relationship and cannot perform this action.  For these scenarios, you would need to modify your WebInspect proxy configurations to select "Explicitly Configure Proxy" and specify the necessary credentials.  You may need to also configure proxy settings in the various tools found in WebInspect as well.



    You mentioned specific trouble with the Manual Step-Mode Crawl.  When you utilize this feature, WebInspect turns itself into a localhost proxy and spawns an instance of MSIE automatically preconfigured for the dynamic proxy port WebInspect is utilizing.  It is quite possible that you have protective applications or Group Policies running on your workstation that are interfering with this automated hooking action, and are perhaps resetting the proxy port dynamically back to your default network settings rather than to WebInspect's port.  You may need to get your network team involved to correct this for your machine.


    Now if you wish to use an alternative browser with the Manual Step-Mode Crawl, you must leave the IE window open to "hold" the recording mode in the "On" position.  You would then need to configure your other browser manually for the proxy port, but you will not know what that is, right?  So stepping back a bit, you would need to open the Edit menu > Application Settings > Step-Mode panel and change the Step-Mode behavior from using a dynamic port to a specific one such as 8081.  Once you have this set, any Manual Step-Mode Crawl you initiate will be using that static port, making it simpler for you to configure your favored alternative browser.


    Once you complete the Step-Mode phase, you would return to the WebInspect UI and click the "Finish" button to end that.  From there you could right click a session in the Site Tree and opt to "Crawl From Here".  Or you might prefer to skip the automated scan phase and go right to Auditing by clicking the Audit button found in the WebInspect Toolbar area.




    So in the end, you must identify where the issue lies for your installation.  Here is a basic flow of the HTTP traffic for you to consider this.


    1. WebInspect automated scan:


            [ WebInspect > network proxy > scan target ]


    2.  WebInspect Step-Mode crawl:


            [ MSIE > WebInspect (on port 8081 or dynamic) > network proxy > scan target ]