Property with name 'auditassistant_enabled' not found in SscPropertyServiceImpl

An error occurs during tomcat .war deployment!! Fortify ver. 20

  • Hello ,

    Are you trying to upgrade Fortify SSC to v20.1 or is this a new installation?

    If you are upgrading to v20.1, are you able to reach the configuration wizard page? If so, make sure to generate the migration script as part of the database connection page and execute that script on your SSC database.

  • It's a new installation. Besides, the guide for the installation refer to a very old version of MySql (v.4.5). My MySql installation is v.8.0

  • Verified Answer

    There is a doc bug filed regarding this. One of our techs reported the following:

    I actually successfully installed SSC 20.1.0 with MySql 8.0 in Linux by using the following my.cnf, where I had to comment query_cache_type, query_cache_size, innodb_file_format, innodb_large_prefix:

    [mysqld] datadir=/var/lib/mysql socket=/var/lib/mysql/mysql.sock user=mysql # Disabling symbolic-links is recommended to prevent assorted security risks symbolic-links=0 # # Modifications for Fortify SSC and Mysql 8 # max_allowed_packet = 1G innodb_log_file_size = 512M innodb_lock_wait_timeout = 300 #query_cache_type = 2 #query_cache_size = 128M innodb_buffer_pool_size = 512M default_storage_engine = INNODB #innodb_file_format = Barracuda #innodb_large_prefix = 1 sql_mode = TRADITIONAL collation-server=latin1_general_cs character-set-server=latin1 [mysqld_safe] log-error=/var/log/mysqld.log pid-file=/var/run/mysqld/mysqld.pid [mysqldump] max_allowed_packet = 1G