WebInspect WIE 17.20 Firefox version upgrade?

When attempting to record a web application for scanning using the Firefox rendering engine, the application will not function correctly as it detects an old verion of Firefox is being used (v30.0.0.6397).

Is there any provision for updating the Firefox version used as the engine?

  • Verified Answer

    There's no way to change the embedded version (and still have things work) unfortunately. Plans are in place to upgrade the embedded browser with a newer version, however.

    It is possible to spoof the user agent, of course, if that's your goal (basically tell the application under test that you are whichever browser you wish to appear to be). Look at the scan settings - cookies/headers for this functionality.