LIM Initialize Error creating Database

I have just installed WebInspect 17.10.

I also have an instance of SQL Server 2014 running.

When trying to create the Licence Server Database I receive an error 'Must declare the scalar variable "@ScanID"'

This is at the point where I have entered a name for the database and then clicked Create.

Can anyone help with this issue?

Is Licence Server Manager LIM compatable with SQL 2014?

Thanks in advance

 

  • LIM doesn't use SQL Server - it uses an embedded version of SQL Compact Edition for its database.

    Are you perhaps confusing the LIM database with the WebInspect database?  The error you are seeing is, I suspect, a collation issue.  WebInspect requires the database collation to be case-insensitive.  I suspect you have it set to case-sensitive.

  • Sorry My Apologies.

    Yes I was trying to run Web Inspect 17.10 for the first time when it asks you to either connect to and existing server or close and Install SQL Express.

    I have tried both options.

    1. Running a SQL Server 2014 instance and when I connect to it and say "Create Database" I receive the Must declare @ScanID error.

    2. I then installed SQL Express on the same server (downloaded from the link provided on the pop-ujp window SQL express 2012) then when I run WI I get the cannot find SQL Express, do I want to connect to another DB server or Close and download SQL.

    So at this point deadin the water

    Thanks for any advice

    Chris

  • Verified Answer

    Make sure you only have one version of SQL EXpress on the machine at a time - if there are multiples then that can lead to WebInspect not seeing the instance.  Uninstall any others - or uninstall all if you're not sure and then reinstall just the desired version (17.10 works with 2012 SP1 and 2 or 2014 SP1 or 2016).

    The ScanID error is definitely a collation issue.  If you resolve that - make sure the SQL Server instance has a collation that is Case Insensitive.

  • Thanks. That was the issue along with differing versions of SQL running

    Uninstalled them all, Installed SQL 2014 and it worked fine