TFS Plugin - SSC 18.10 Integration

Hi! We currently use Fortify 18.10 and TFS 2015
I configured TFS plugin. Test Connection is ok but when I try adding a new Bug I get 

ERROR | pool-11-thread-2 | BugTrackerLegacyMessageHandler | 9 - com.fortify.plugin.camel.bugtracker - 1.2.187 | Error while handling BTFileMultiIssueBug Error when filing a bug to the TFS Collection XXXXX

Looking at Event viewer in TFS server, the message error is:

TF01320: Rule error for field Description. Error code: Required, Invalid empty

But the default TFS template has that field and I complete it.

Do anybody know how to resolve this?

Thanks in advance!


  • Hi,

    It appears bug is being logged after selecting multiple issues in SSC. Correct me if I'm wrong.

    Has there been any changes to the default bug submission template when multiple issues are selected?

    I have tried SSC 18.10 bug tracker integration with TFS 2015 and cannot reproduce this problem with default settings.

    Tejesh Chandra K H


  • Hi Veronica,

    I think this is a well known bug.
    It will be fixed with the release of Fortify 18.20.
    As workaround I would recommend to use the VS-17.20 plugin.
    There is a hot fix for 18.10.
    You can request for it at the fortify support and refer to bug OCTCR11A152060.


  • Hi Tejesh! Thanks for your reply.

    It happened with single and multiple issues. The bug had some required fields but not Repro Steps which is the field the plugin maps against Description.

    In a lab environment it worked ok when I left only Title and Repro Steps as required fields. But it isn't the default in production.

    Best regards,


  • Hi Homan! Thanks for the reply.

    In a lab environment it worked ok when I left only Title and Repro Steps as required fields. But it isn't our default template. And I was testing with a replica of the Production environment.

    I think I will need make some changes to the java code in the sample plugin to adapt it.

    Best regards.