This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

.NET Framework 6.0 Support

Where can I find when Fortify SAST is going to support  .NET Framework 6.0?

Thanks in advance!

Tags:

Parents
  • To add a few data points here:

    •  ".NET Framework 6.0" doesn't exist as such. There was a time (until 2019) that Microsoft developed ".NET Framework" and ".NET Core" in parallel. This latest versions of those are ".NET Framework 4.8.1" and ".NET Core 3.1". After that, ".NET Core" was renamed ".NET". We have seen versions ".NET 5.0" and ".NET 6.0". ".NET 7.0" is scheduled for November 2022.
    • When discussing what Fortify SAST supports, the first question is usually: what can it scan? Regarding that question: SCA 22.1 currently supports ".NET 6". That's in the supported languages list.
    • The link that naikro provided is about the platforms that Fortify can run on. Specifically to translate .NET and Visual Studio C/C++ projects, Fortify SCA uses ".NET Framework". As per the guide, this needs to be 4.7.2 or later; the newest one possible is 4.8.1. It will not be able to use ".NET Core" or ".NET" for this purpose as these are not compatible with ".NET Framework"
  • And if a diagram/picture can help in any way...

Reply Children
No Data