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Knowledge Doc: WebInspect API not showing all scan results

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Summary
If you run a WI scan, WebInspect API does not show the scan in the scan results list.

Products
Fortify WebInspect

Environment
WebInspect (WI)
SQL Express

Situation
Unable to get the list of scans using the WI API. When the Scan ID is provided to fetch the results via API, the WebInspect API gives an error of "Scan not found".

Cause
When using SQL Express, scan data is stored under the user profile. The WI API by default runs as Local System and not the current logged in user, preventing it from accessing the scan data for the user running the scan.

Resolution
Change the "Log on as" setting for the WebInspect API service from Local System to the current Windows user, for example: ".\Admin" or "domain\username".

Please note that if you have any scans in the Local System profile, you will need to copy those scans to the current service profile.


Knowledge Base Article Link

URL Name
KM000015599

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