Require TLS for Simple Binds with Password set to Yes by configure.sh

I don't know if it makes sense or not, but I'd like to clarify what has happened.

I upgraded an IDM 4.6 to 4.7, installing it in a new server. On this new server, I installed eDir 9.1.4 and IDM 4.7. When I executed the configure.sh on this new server, it seems it changed the value of "Require TLS for Simple Binds with Password" of the old eDirectory server to "Yes".  It was previously set as "No" and we have noticed it because users have stopped being able to authenticate with LDAP by not using LDAPS. It has served, of course, to detect this security problem. Something that is always positive, but I would like to know what has caused the change.

Regards

Jose Luis