How to fix role delete stuck in pending state

I tried deleting some roles but they are now stuck in a pending state. This happened because the vault running the rrd driver stopped syncing with the other vaults. We moved the rrd driver to a new vault and repaired the misbehaving vault, but now I can't get the role out of the pending state.

I've tried sending the delete through again but I get this message in the UA log:
2019-03-01 17:39:25,235 [INFO] RoleManagerService [RBPM] One is attempted to delete a role already flagged for deletion. If role is not getting deleted in a timely manner, make sure your role resource driver is current and running. More details can be found under NetIQ Bugzilla Bug 685263 - ENH: Improve the revocation process when deleting a Role with Resources or Removing a Resource from a Role


I found this article but it doesn't explain how to fix this situation: https://support.microfocus.com/kb/doc.php?id=7013290

I can delete the role object directly in eDir, but I am guessing there is more to a role delete than simply deleting the object.

My hunch is that I should change the nrfStatus value which is currently 15.

Any thought?